1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I need help guys, Race07 doesn't install.

Discussion in 'RACE 07 - Official WTCC Game' started by Frankl Mate, Oct 8, 2012.

  1. I have a copy of Race07 but i have an issue installing and launching it.
    I have been trying to install it for 1.5 weeks now and the same error pops up when i click on the Install button.
    "No Steam content servers are currently configured to deliver content for this game. This will be corrected soon. Please try again in a few minutes."
    Because of this I have tried to set my location to Germany, Austria, Australia, USA, China from Hungary. Nothing works, i get the same message.

    I have also tried to uninstall the whole Steam with the game installed and do a clean, fresh install. It did not solve the problem.

    When i install the game from the DVD it installs correcty but the game cannot be lauched because i get the same error message popup again: "No Steam content are currently configured to deliver..."

    I read on multiple forums this isn't a unique problem. Lot of people suffer from this since the last update (2012 September). Anybody has a solution? (no, i'm not gonna reinstall my win7 x64 just because someone ****ed something up at Steam)
  2. It sounds like either a firewall issue or an anti-virus issue to me, though it might also have to do with Windows UAC. I know you have been uninstalling and reinstalling, but if you don't mind let's try one more time but with some changes.

    Reinstall steam, but not in program files folder. Instead make a folder in the root of the C drive, call it something like Game Apps or something and install there. Once you have Steam installed and before you install Race, make sure you can go to the Steam store. Try and download a demo of anything just to make sure it works.

    Next step would be to install Race. If you created the folder and named it as I have suggested, then the install directory would be C:\Game Apps\Steam\Your Name\Race 07.

    Once the game is installed, turn off your Anti-virus and firewall or if you know how, make exceptions for Race and Steam in those programs. Launch the game and see what happens.
  3. I don't think that's the problem. (I had a full win7 reinstall in September. I did not really have time for games in the last month that's why i didn't install any games.)

    I can install other games (even GTR Evolution, but obviously it doesn't start without race07) in Steam. Portal, Alien Swarm installed perfectly and can be played. The only game i can't install online is Race07.
    I also tried to start Steam with admin rights, but no result.

    This must be a Steam related issue, because from the DVD Race07 installs but cannot be started. But when I try to install it through Steam it doesn't even install.
  4. Dennis Phelan

    Dennis Phelan
    Let's just get out there and RACE!! Premium Member

    It's been a long time, but if I remember right and you try a direct install of GTR Evo, the first thing that happens is an install of Race07?
  5. Bram

    Roaring Pipes Maniacs | #27 Staff Premium Member

    That happens only when you have the GTR Evo full game bought :) In this case its an expansion pack I presume?

    Have you tried to force a steam update Frankl?

    1) Remove the two *.blob files in your steam folder. 2) exit and end Steam 3) Start Steam 4) Login with username and password 5) Repeat the install process.

    See if that helps
  6. Yes, you are right it's a standalone Race07 and GTR Evo expansion pack dvd.
    I tried what you suggested Bram but it did not help.

    I'm just guessing but the problem might be that I have the hungarian version of the game. And it's still shitty while the english version is fixed.

    As you can see there's no trouble downloading the GTR Evo expansion (even though it won't launch without Race07 so it's useless)