1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Help with custom objects

Discussion in 'Bob's Track Builder' started by nferraz, Apr 12, 2009.

  1. Hi A I am having alot of trouble getting custom objects to work well with BTB. I have created 3 diferent buliding structures with cad software and exported them to 3ds format. Everthing goes well with one object but the other 2 i get this error when I export to Rfactor.


    ************** Exception Text **************
    Error in the application.
    -2005530516 (D3DERR_INVALIDCALL)
    at Microsoft.DirectX.Direct3D.BaseMesh.Clone(MeshFlags options, VertexElement[] declaration, Device device)
    at BobsBits.rFactor_GMT.PopulateFromObjectGroup(rFactor_ObjectGroup ObjectGroup, Vector3 Offset, String Name, Venue Venue)
    at BobsBits.rFactor.rFactor_Venue.AddObjects()
    at BobsBits.rFactor.rFactor_Venue.CreateAll(Venue Venue, Vector3 Offset, String VenueFolder, String TrackFolder)
    at BobsBits.Venue.ExportForrFactor(String ExePath, String VenueFolder, String TrackFolder, String VenueName, String TrackName, Boolean OverwriteTDF, Boolean OverwriteGDB, Boolean OverwriteSCN, Boolean OverwriteAIW, Boolean OverwriteCAM)
    at BobsTrackBuilder.frmExport.butrFactorExport_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ButtonBase.WndProc(Message& m)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)



    I suspect there must be some errors with the object like size, polygon count etc.. but i have no idea what to fix. Does Rfactor have some kind of limitation in regards to 3d objects size, poly count or any other parameter? Most likely I should import it to 3dsmax to fix errors, but I have no experience using this application and from what I hear it is very complicated to use.

    Help will be very much apreciated.

    thx
     
  2. hi sorry didnt know that info was usefull, I´m using BTB latest version. I am using Chief architect and exported in 3ds format.I have no trouble importing the objects into an xpack and then BTB but only when i export to rfactor. Today another problem came up.
    I made an Sobject of a fence segment and placed this on both sides of the main straight.Everythig goes well in BTB but when i expoerted to rfactor it took about 10 min or so to export. When iwent to test the track in rfactor the track does not appear.
    T he folder exists and the content but it does not show up in rfactor. I chcked the folder size and it was something like 130 MB. I´m guessing that rfactor has some limitation with 3d objects.I´ve googled fot info on this but cannot find anything. Its becoming very frustrating
     
  3. Sorry I´m using P4 2,6 , 2GB memory 233mhz, Nvidia GS7600.

    Thx in advance