1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GSC config: Video Setup 1.7 problem

Discussion in 'Stock Car Extreme' started by Duvels, Nov 8, 2013.

  1. Hi all,

    After I read the (very) positive reviews of this game, I decided to buy a copy. So I got my serial number via mail and downloaded the game. Installation went fine, I then activated my copy, but now I can't continue.


    When I start the game, I get the video setup as you can see in the screenshot. My first concern was that I couldn't select my normal GFX card: a nVidia 540M. I still tried to continue as my nVidia settings are set to always use the GFX card (or Powerful NVIDIA-processor as they call it). However, the video setup screen then disappears and after a second re-appears, with the standard settings. I tried to run the GSC config with administrator rights. Problem then is that the settings are saved for the GSC config, but when I try to fire up the game again, that screen again appears, and again with the standard settings. I also tried running the game with administrator rights, but that didn't solve it either.

    Does anybody has an idea what to do next? Thanks in advance!
  2. pil


    First you have to run the game once using your integrated graphics
    .Goto your 3d settings and tell your GSC exe to run using integrated graphics.Run the game then exit after the main screen comes up.Go back to your 3d settings and change back to the nvidia graphics card then game should run.If that doesnt work try running some of the previous nvidia drivers.I am using the 327.23 ones as the latest dont seem to work for me.
  3. Thank you for your quick reply, pil. I tried to run the game using the integrated graphics, defined by the 3d nvidia settings, but that didn't work. I also updated my drivers for the GFX card (I was still running very old ones :redface:), but no help either.

    After some extra googling, I found the next thread: http://www.racedepartment.com/forum/threads/issue-detecting-graphics-card.66415/
    Niall Fitzpatrick seems to have the same issues with Formula Truck and used the config.ini file from another game (GSC, the original one I think) to replace the FT file. That seems to work, but I don't have older Reiza games.

    Another user, nielty, has the same problem, but the config swap didn't work for him.

    Common factor seems to be the gfx card as we all three have a nvidia GT5xxM.

    Randy Chamberlain suggested to check my bios, so I'll try that and report back.

    EDIT: I can't find any option in my bios to change something about my gfx card or the integrated graphics. Looks like this one won't be playable for me on my laptop :(
    Last edited: Nov 9, 2013
  4. pil


    try the 327 drivers.These are the latest ones that worked for me.Anything after that (331 drivers) dont seem to work on mine.
  5. Ah sorry, I forgot to mention that I indeed updated to drivers 327.23 and not the latest version. Before this, I was running something like version 304.

    EDIT: I have a breakthrough, inspired by http://steamcommunity.com/app/8600/discussions/0/828925849267208342/ (although I don't have problems running Race07, GTR2 or rFactor)

    What I did was having both the executable as the config executable run the integrated graphics as standard by selecting that in the nvidia 3D configuration. The game started (first time!), but I already had lag while running the opening sequence from Reiza.

    I then configured the game executable to run with the normal, "powerfull" gfx card, but kept the config executable to run the integrated graphics. The game started again, without stuttering during the opening sequence.

    Final attempt was then running the config executable with the normal gfx card as well, but the game wouldn't start in that case.

    It seems you have to select integrated graphics for the config executable only. However, when you do that, the config program still doesn't recognize the normal gfx card.
    Last edited: Nov 9, 2013
  6. I have the same problem...
    Laptop with integrated and "power" graphic card. (GF555m)
    Purchased the game, download, install and start. I had the choice of enter a key or test 60minutes. For sure I entered my received key. In next step the video setup popped out and I only had choice of pick integrated card.
    Click ok, window close, window open.... OMG!
    I tried ur tips with nvidia configuration, nothing changed for me. Driver ist 327.23 also...

    Gettin really mad about this!!
  7. Hey guys, I just ran into the same problem today after buying the bundle.
    Even though GSC2012 ran perfectly fine and after selecting the executables in the Nvidia Control Panel, my GTX660m showed up perfectly fine in the configurator, I could not get it to work with GSC2013 or Formula Truck.
    After 30 minutes of so of trying different things, I noticed that the d3d9.dll file in my GSC2013 had a different size than the one in the GSC2012 folder. Formula Truck had the exact same size as GSC2013. So I tried copying the file from 2012 and the video card showed up perfectly fine in the configurator.
    I tried later and also deleting or renaming (recommended) the d3d9.dll file from the folder seems to work as it falls back to the DirectX files installed on your system.
    I remember that the d3d9 file is included in the folder to make the trackmap plugin work. I don't think it has any other reason for being there. If you delete the file the track map will not show up, but if you replace it with the file from GSC2012 it will work fine.
    Also, if you delete the file you can Alt-Tab out of the game and you can return to just fine. With the the new file you can't enter the game after you return to desktop. I deleted the original file and can't test with that one, but maybe someone else can try it out.

    Here is the link to the file that works for me. Back the old file up just in case and to be able to run more tests (rename it with .bak extension or copy it some other place).

    I would love it if a developer came in here and gave us his opinion on this and what are the differences between the two files.
  8. jimortality

    Premium Member

    Strange as I have the GTX 660 and didn't have any install issues at all with either game.
  9. I'm talking about the GTX 660m, the mobile variant of the video card that is installed on my laptop along with an Intel HD 4000 series chip. There is some Nvidia tech called Optimus that does the switching between the two to improve battery life when not playing games.
  10. jimortality

    Premium Member

    I see hope you get sorted.
  11. Thankyou Mihail, it works , you saved me!
  12. Hi guys,

    i will this thread to show you , the problem i have since i´ve installed (yesterday) the game.I can´t set the resolution.

    On the right pic, it´s the setup from rFactor ...Wich works perfectly , but on the left the one from GSC2013....All "BLANK".

    I use a NVIDIA GTX780 TI on triple screens...My drivers are updated........


    Any ideas?

    In advance thanks.
    Last edited: Jan 28, 2014
  13. No one have the answer ? please ;)
  14. Rupe Wilson

    Rupe Wilson
    Keep Yoga real Premium Member

    hello sorry ive not seen this till today,
    yep i know that problem..:)
    there is something wrong with your pc, i never found out the real problem , but the solution for me was to take out the
    d3d9dll from inside the game folder, this is for the track map and it was
    causing me problems.
    once i had taken this out i could set the resolution, if i put it back in i had the problem return.

    in the end i did i re-install of windows and all worked like a charm again.
    so its a dx9 problem as far as i could figure.

    so try taking ou the d3d9.dll and see it you can set up the config again.
  15. Thanks for your help,

    i will try that ;)

    What do you think if i take the DLL from rfactor and i put it in the GSC folder?

    Beacause with rFactor it works perfecly .....
  16. It works fine...Thanks a lot....

    PS: support @gscsupport , not really responsive ;).

    Two e-mails sent and no reply .....

    Here action/re action lol.

    Cheers .
    • Like Like x 1
  17. Hi

    I installed Game Stock Car Extreme (v 1.15) this morning and am also unable to get GSC Config Video Setup Setup (v 1.7) to recognise my preferred GPU. I have a gaming laptop with NVIDIA GeForce GTX 680M in addition to HD400 on-board Intel graphics.

    The video config screen appeared automatically as part of the initial installation but only showed the HD400 so I tried to use NVIDIA's 3D Settings panel to make the GeForce card the default for GSC.exe

    This did not cause the GTX 680m to appear in the dropdown list (and right clicking the game's icon to TELL IT to use the better card doesn't work either).

    To get the sim' to start I accepted the default (very low) graphics settings of 800x600 16 bit at 40Hz and now, having exited the game, if I start it again the config screen does not pop up automatically.

    Now, if I want to access it, I can do so by selecting GSC.Config in the game folder.

    It opens but my GeForce card still isn't listed.

    If I remove the d3d9.dll file is the GeForce card supposed to show in the list ?

    I have tried removing it from the folder and I have tried replacing it with the variant that Mihail Serafim kindly made available - but I still can't see the preferred card.

    Should I be ABLE to or have I missed a step ?
  18. So, I've recently bought a new computer and was excited to try the game on my GeForce 940M. Turns out I'm having the same problem as these people. The game actually runs fine on the integrated board, but I'd like it to recognize my dedicated one. I've tried forcing both the game and the config utility through the nVidia application, to no avail, as well as some of the tricks shown above, except installing older drivers, which I'll leave as a last resort (it is a brand new PC, after all). Any ideas?
  19. Fabio Rodrigues

    Fabio Rodrigues
    Reiza Studios Community Manager

    That's weird, forcing it through nVidia should work. Have you tried disabling the integrated board in the Device Manager? It isn't ideal, but should work as a last resort.

    (in the future, please don't bump very old threads. It's better to post in the bug report/feedback thread :) )
  20. Well, to be honest, installing older drivers is preferable to flat out disabling a piece of hardware haha
    Isn't there any other, less drastic, solution? I might try the 327 drivers if nothing comes up, but I'm starting to think that maybe sticking with the intel board is a better solution for the time being. Thank you for the suggestion anyway, I like how friendly and helpful everyone is on these forums!

    Oh, and sorry for the bump, I didn't know it was bad form! :confused: