1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

GSC 2012 setup self-closes upon execution

Discussion in 'Stock Car Extreme' started by Mauricio Vittorazzi, May 14, 2013.

  1. Hi mates.

    I'm trying to install the GSC 2012, but when I run the installer, the language selection screen appears and the installer closes then. Already downloaded the installation again because they could be corrupted (I already have the first version so I downloaded the updated one), but the problem continues. My user is an administrator on the computer, so I think it is not permission problems. No anti-virus blocking the application or other software that could disrupt running the installer.

    Reiza's official support center told me to download the DVD files, but personally I think they haven't understood my problem.

    Maybe it's some king of activation issue with my serial key, but... Could be possible that the installation check my registry in the execution of the setup application instead of doing it in the first execution of the game?

    Anyone out there had the same problem or something? I'm out of ideas.

    P.S.: I've already posted this on the PT-BR session. Sorry for this double-posting, but they're kinda dead...
     
  2. Joe Moore

    Joe Moore
    Premium Member

    Do you have MSI AFTERBURNER running in background ?
    Have you tried running the demo ?
     
  3. I need to check closely. It runs like a hidden process (that doesn't show up in taskmgr)? Because I haven't noticed anything like that.

    I'll get the demo version and try to run too, maybe this can tell me anything.

    Thanks, mate.

    @off

    Just to share my experience with Reiza's tech support: They sent my help request to the marketing sector and the girl that is in contact with me, after a few messages, told to install the game on another computer, copy the installed data to a flash drive and then copy from the flash drive to my computer. Well, I don't know about you guys, but that doesn't sound like a professional tech support sugestion to solve a problem (different from what Joe Moore, that is not a support technician, suggested me to do).
     
  4. Even if your user is an administrator, I would make sure you click on 'run as administrator' in case it helps.
    If you are still stuck I would try turning off UAC
    (Control Panel/User Accounts & Family safety/User Accounts/Change User Account Control Settings/ select Never Notify ). this might then allow the installation.

    Also, Microsoft Security Essentials definitely caused installation problems with previous versions of GSC. Make sure this is off while installing.
     
  5. Hey Keith.

    I tried to "force" the application to run as admin and turned off MSE monitoring services too, but nothing have changed. I also have UAC turned off since I've first formated and installed my OS (I hate that UAC thing).

    It's really strange because a week or two before the problem started I've installed the game without any problem at all to make some tests. Then I've uninstalled it and, when my wheel finally arrived, decided to re-install it...

    Thanks for the attention, Keith!
     
  6. OK, I think we are missing something obvious here. You need to check exactly what you have downloaded and are trying to install.
    On the GSC site, downloads page, as far as I can see, you can download the demo, OR the update to 1.2
    BUT if you want to install the complete game, you need to download all three parts from the try/buy section, put them all in the same folder and double click the first part.
    So what version of GSC do you have on your system, and are you definitely using the correct files?
     
  7. I had the first version of GSC before. Then I saw they released the 2012 season update and downloaded the 2012 version files (not the update files, the full 2012 version) and installed it without the previous version installed on my PC. All runned perfectly: Installed successfully, activated with my previous version serial key and played a lot... Then when I uninstalled it and tried to install using the same files that I've used before, the problem started.
     
  8. OK, I did have a problem on a previous version when installing, it was not the same problem but it is worth a try:

    1)make sure the game is uninstalled
    2) go into c:\ programdata folder (may be hidden, you have to tick 'show all folders' in folder options), and delete the reiza folder. It seems to be empty, but it was important to delete this.
    3) try to install game again.
    Of course you will then have to reactivate the game once installed.

    If this doesn't work, then I can only suggest using a registry cleaner to wipe all traces of the game from your system (plus delete the hidden reiza folder) before trying again
     
  9. I've checked the hidden folders in documents, users and system directories too. Deleted all of them, but maybe there's still something lost anywhere... Luckly the sales girl have already restored my serial key activations, heh.

    I'll check that and the registry later after work (Wish I had my remote connection still working *sigh*) and post any feedback here.
     
  10. Well, as I expected, it doesn't worked. The registry was clean, also the folders. Disabled the MSE and nothing have changed.

    I'm downloading the demo right now to see if it happens with it too.
     
  11. Just tested the demo setup. Same problem.

    Maybe I should stay with F1 2012 then. :p
     
  12. No man, don't play F1 2012, it is lame compared to GSC 2012.

    If you are using a free anti-virus, like AVG, then uninstall it completely first and reinstall it later after you get you game installed correctly. Most free anti-virus programs are crap anyway.

    I would simply re-download all of the setup files, make sure they are all in the same folder.

    http://sim-racing-evolution.fr/downloads/root/jeux/GameStockCar/GSC2012_V120_Digital_Setup.exe

    http://sim-racing-evolution.fr/downloads/root/jeux/GameStockCar/GSC2012_V120_Digital_Setup-1.bin

    http://sim-racing-evolution.fr/downloads/root/jeux/GameStockCar/GSC2012_V120_Digital_Setup-2.bin

    When the install starts, make sure that you install to:

    C:\Program Files\GSC2012
    - or -
    C:\Program Files (x86)\GSC2012

    Don't install directly under C:\GSC2012 , mainly because it makes it more difficult later when you install tracks and other stuff that default to your program files folder during install. When my friends install a new track or a car skin, they always install it to the wrong location, because they made the mistake of installing the game directly under their C drive - and the track the installed wound up in their program files folder.

    Are you able to select a language during the install? If so, then what language are you choosing? Maybe try a different language. I know the English install worked fine for me.

    You could always install XFire and add me as a friend "suicidal8000" and then install TeamViewer and I could connect to your pc and try installing the game for you and I could check everything to make sure it is being installed properly. I am very technical and I bet I would get it working for you. I help tons of friends on TeamViewer all the time when they have problems with stuff and I've never failed to fix a problem.
     
  13. Just kidding!

    The setup closes less then 1 second after I start it, as I said. As I in the past used to make some torture tests with my PC, I always install my OS in another partition of the disk. So I have 2 partitions, the first secured with my system files and the second with my personal files, docs, games and that sort of things... Also, I always install all games into a "\games" folder, to keep things organized.

    I am postponing my regular system formating for a long time. Maybe that's some signal that I need to stop procrastinating. Haha! :p

    What I've already done and didn't worked:

    - Disabling anti-virus services.
    - Redownloading the game setup files.
    - Downloading the demo version setup and trying to install.
    - Clean the game temp folders and registry files.
    - Pray for the gods of racing.

    I don't know if I have uninstalled something important that could be affecting the setup execution. I had some SQL Server and Visual Studio tools installed (I'm a programmer) and have uninstalled them a few days ago, before the problem started. But I think this have nothing to do with my issue...

    Thank you all for the helps. I'll keep trying other sollutions.

    I don't use Xfire or other social gaming apps, but I thank you for the intention to help.