1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Let's Play: F1 2017 The Game
Click the cross to dismiss this video
Join the conversation on Youtube by clicking here

graphics problem or what???

Discussion in 'F1 2010 - The Game' started by georget_th25, Oct 5, 2010.

  1. georget_th25

    georget_th25

    Messages:
    39
    Ratings:
    +0
    when i play the game full-screen makes small lags. when i play it in small window its perfect... both at medium graphics... WHY??? what can i do to play f1 without lags at full-screen????

    i have laptop with win7 64bit, intel core duo p7550 @ 2.26ghz 2.27ghz, ram memory 4GB and ati mobility radeon hd 4650 1GB

    Please help me...
    ps* sorry for my english...
     
  2. Ian Mckenzie

    Ian Mckenzie

    Messages:
    20
    Ratings:
    +0
    buy an xbox 360....sorry
     
  3. Bowen Walker

    Bowen Walker

    Messages:
    7
    Ratings:
    +1

    the game is very heavy on system resources, i would not recommend playing it on a laptop
     
  4. Derinahon

    Derinahon

    Messages:
    106
    Ratings:
    +6
    Your processor doesn't meet the minimum spec.
     
  5. velocityx

    velocityx

    Messages:
    54
    Ratings:
    +0
    haha thats funny, considering that the game on the consoles stutters and looks just bad.
     
  6. John Parnell

    John Parnell

    Ratings:
    +0
    got it on Xbox360 and PC, much much better on PC :)
     
  7. Andrew Macpherson

    Andrew Macpherson

    Messages:
    265
    Ratings:
    +8
    A small window is much easier for your computer to display than full screen. Your only hope is to turn the graphics settings down as low as you can. You might need to turn off anti-aliasing too.
     
  8. georget_th25

    georget_th25

    Messages:
    39
    Ratings:
    +0
    i have PS3 but i like to play F1 on my laptop
     
  9. georget_th25

    georget_th25

    Messages:
    39
    Ratings:
    +0
    ok thx..
     
  10. Eeshan

    Eeshan

    Messages:
    35
    Ratings:
    +0
    Turn Of MXSAA to 0x, Vsync should be OFF, and get the latest drivers for ATI. 10.9 is the latest one out there. best of luck