• "Auto racing began 5 minutes after the second car was built." - Henry Ford
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Gpu usage 20%-40% less using openvr mode with rift

Discussion in 'Assetto Corsa' started by divxmaster, Sep 27, 2017.

  1. divxmaster

    divxmaster

    Messages:
    7
    Ratings:
    +3
    Check out my thread here:

    http://www.assettocorsa.net/forum/index.php?threads/vr-performance-in-oculus-vs-ovr-modes.47367/

    Update: Something big has changed in the oculus update yesterday and the one the day before, OR mode now has much improved performance, matching OVR mode.

    I will include a guide here, in case you do not have a verified account at assettocorsa.net

    This will lower your gpu usage 20-40% in openvr mode with the rift.
    Under render settings, change to' Openvr early access' instead of 'Oculus Rift'. AC will start steamvr when you start race/rift mode.
    Note I have a GTX1060, not overclocked.

    Have run many tests, initally in practice at lake louise in the lotus 3-eleven. In Oculus Rift mode (OR), I get 5% headroom (using oculustool), in OpenVR mode (OVR), I get 60-65% headroom!

    At nordschleife, with 12x opponents, 4xAA, 16xAF, reflections low, mirror normal, smoke normal, BrakelightVR PP, world detail Maximum, Shadows disabled, I get 90 fps constant. On a gtx1060. This nearly matches the options a user mentioned, when he was in OR mode, on his GTX1080! (my smoke settings higher, his with shadows on).
    *update: tried the above with shadows on (low), still 90 fps after the first corner.
    *update2: frame rates are inconsistent with shadows on... some runs I get 90fps, others I get 45 fps a lot... dropped to 9x cars and its all good. Might turn shadows back off.

    Notes:

    Sometimes it does not activate properly, and will get a really low frame rate (I've seen -95% headroom). In this case restart everything, or reboot.

    Occasionally steamvr crashes, wont close, loses steamvr server

    OVR mode doesnt seem to like high reflections combined with high AF on some tracks. It spikes up and down in frame rate. especially when you look down, which is weird.

    Other users have got this working successfully also, some others have not. We do not know why at this time.

    I do not use SSAA/supersampling, I find inbuilt 4xAA way way better at antialias.

    All steamvr reprojection etc, is OFF.
    Oculus Home must be left running.

    The screen mirror seems to be a 'true' mirror. i.e, rendering at 1080*1200 then resized to 1920x1020.
    Therefore the aspect ratio is wrong. This could be corrected if you process the video, but not sure about streaming.

    Thanks to user detoit, for mentioning openvr mode on his vive, which make me think of trying it on the rift.

    Cheers,
    Divxmaster
     
    Last edited: Sep 29, 2017
    • Like Like x 1
  2. JoelGL

    JoelGL

    Messages:
    1,146
    Ratings:
    +84
    Thanks for this tip! Tried with Content Manager, set Rendering to Open VR (early support?), run a sample race but I get pauses when on-track. Any idea why? I'm not using SteamVR is not in beta. (i5-4670k / 980Ti/16Gb RAM)
     
  3. Stuart Gillard

    Stuart Gillard
    Sir Ropey Premium

    Messages:
    230
    Ratings:
    +90
    I'll be testing this later on, I'm happy with the performance I get at the moment in VR in AC so if I can turn a few more effects on or set them higher well it's just a win win situation..! :D
     
  4. divxmaster

    divxmaster

    Messages:
    7
    Ratings:
    +3
    @JoelGL, I've havent used content manager so far... not sure why it is pausing for you. do you set the render device in content manager?
     
    • Like Like x 1
  5. JoelGL

    JoelGL

    Messages:
    1,146
    Ratings:
    +84
    Thanks. Can you share your PP (for brake lights only). I tried turning PP off and got mostly 90, so this is what's hogging my resources. I was using gbw Vanilla PP. So I'll try using your PP.

    PS. what's your CPU?
     
  6. divxmaster

    divxmaster

    Messages:
    7
    Ratings:
    +3
    Hi,
    detoit is the author of that, here:
    http://www.assettocorsa.net/forum/i...re-faint-greenish-when-pp-is-off.43422/page-3

    I am running a 4770k @ 4.2. I see your 4670k doesnt have hyperthreading. I wonder if that is the problem.... I have had the >99% cpu usage come up once. But not in a couple of weeks though.
    Your 980ti should be 30% faster than my gtx1060.
    I've redone the first post, if you haven't seen that, go through the notes part.

    Cheers,
    Divxmaster
     
    • Like Like x 1
  7. JoelGL

    JoelGL

    Messages:
    1,146
    Ratings:
    +84
    Runs better now, fps was more stable fixed at 45fps anytime a car is in front of mine, unlike before where fps kept moving up/down. I guess its really my CPU that's limiting it at 45fps when it renders a car in front. Will continue playing with settings.... but this is a big improvement. :)
     
    Last edited: Sep 28, 2017
  8. divxmaster

    divxmaster

    Messages:
    7
    Ratings:
    +3
    yes sounds like it... unless you have every setting on maximum your 980ti should be ok with it in ovr mode.