1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

gMotor Material plugin not working with 3ds max 2009

Discussion in 'Bob's Track Builder' started by Sub, Jan 17, 2010.

  1. Sub

    Sub

    Hello, i've done some digging around, but the only info i can find on this is via google pulling up a dead racesimcentral thread.

    Basically, i've downloaded the 3ds max 2009 gmotor plugin from the rfactor site, dropped those three files in the 3ds max plugins folder and then copied the coreshaders file from rfactor to the 3ds max hardwareshaders folder. The gMotor Materials plugin will show in max, but it's grayed out as "incompatible" if i try to use it anyway, it exports an object without the texture attached to it (though i can get the texture to show up on the object in max).

    I suppose i should also point out, i'm running Windows 7 32bit. Max runs fine on it, so i don't think that's the problem, but something's definitely not adding up right.

    Anyone out there have any idea what the problem could be? Any help would be greatly appreciated.

    ~Sub
     
  2. Sub

    Sub

    Just tried this on XP to see if maybe it was a DX10 issue under Windows 7 - no luck. The plugin still shows up grayed out and marked as "incompatible".
     
  3. Mikec87

    Mikec87
    Premium Member

    Same here. i have Windows 7 RC1 and Max 2009. I can import using the script and the track is there perfectly. All the textures are there, but when I export, the section is invisable....

    So, I have to use Max 8.0 on another HDD with XP and it is perfect. I have not tried to run Max 2009 on XP. Maybe Win 7 is the issue....
     
  4. Sub

    Sub

    Though Windows 7 might also be a problem, i've tried Max 2009 on Windows XP and i get the same thing. I'm starting to think it's a Max 2009 issue, specifically.
     
  5. I installed Max 2009, Got the Plugins from ISI Dev Corner, Copied them to the Plugins folder, and copied the Coreshaders Mas file to the HardwareShaders folder.
    Then i Renamed the 3dsmax.Mat as a Backup and copied my Modding Materials 3dsmax.Mat file and fired up Max 2009, works perfect! :)

    Im Running XP Pro on 4 year old Athlon 2 GHZ PC with 4 Gigs of RAM.
     
  6. Sub

    Sub

    Hmmm - sounds like the exact same way i did it. I gave up awhile ago, though, so my memory might be a little foggy. I'll have to give it another try and see what happens. Just to make sure, you were able to export via the plugin? That particular plugin was grayed out for me and no amount of tweaking things seemed to help.

    Thanks for the response!
     
  7. Yep, I know it sounded too easy, and Ive been struggling along for a while with max 8' as it was corrupting polys and generally crashing a lot lately!
    Give it another go, I can't see why it won't work for you if it does for me!....and I'm enjoying the new features that the 2009 version of max has, I hope to finish my projects now! :cool:
     
  8. Make sure you have the newest ISI tools, as the older versions didn´t support max9,
    it´s easy to mix up the plugins if you have them in a "download" folder.