1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Game loses focus

Discussion in 'Racer Problems & Fixes' started by Gouranga, Nov 23, 2010.

  1. Hi, I have downloaded Racer 0.8.23 for windows. I only tried default car and track. I have following problems:
    1) Game loses focus. I run it in full screen and when I'm in menu, screen flickers and windows taskbar show up. Clicking anywhere in the menu reverts this, but only for a second. Often happens in game as well.
    2) I have about 5 FPS. Controls respond well, sound is also rather good. My PC specs:
    AMD AthlonII X4 630 (2,8GHz), 4GB DDRII ram, GeForce 9600GT 512MB. Same FPS with lowest details in nocg mode.
     
  2. KS95

    KS95
    RACER Moderator

    1) I have the same problem. I'm on windows 7, how about you? I get it with LFS too, but I noticed that holding 'Alt' and clicking on the Racer/LFS logo usually works - not sure why though! :)

    2) Have you tried without shadow mapping? (I assume you can still turn it off in .23)
     
  3. Yes, W7 x64 pro. The Alt-thing doesn't work for me. It's incredibly annoying. It rarely happens while playing rFactor and it used to do with one more game which I can't remember.
    Shadow mapping was off. I have read about people having low FPS because of a control device, someone mentioned MS Sidewinder FF wheel, which is my case as well.
     
  4. I can confirm that the FPS issue was caused by the MS wheel. After I disabled it, I got 250FPS. Anyway the game is no fun anymore. And I have to run it in a window.
     
  5. KS95

    KS95
    RACER Moderator

    That's ironic, in my other home I have a MS Sidewinder FF wheel aswell, and I also had those problems with the FPS. I guess it's time for an upgrade anyways. Sorry I couldn't be more helpful :)
     
  6. I can't believe it is still working, it is an ancient wheel. I remember other's Logitech momo pedals failing after couple of months. The only wheel worth investing is G27 which costs too much considering I'm a student who only plays racing games occasionally. The problem must be related to Racer as it works in LFS, rFactor etc. flawlessly.
     
  7. Alexander Knoll

    Alexander Knoll
    NEVER GIVE UP!!

    hmm...i have the screen flickering too if i use fullscreen...so i use a longe time agoo windowed mode with some pixels smaller as fullscreen with aceptable fps...all grafiks at full power 20-40fps...with racer default values 70fps+, noncg version 500fps+.....
    I'm on win7 x64 Ultimate....
    AMD PhenomII X4 955 (3,2GHz), 4GB RAM, nVidia GTS250 1GB....
    Wheel is the DFP 900°...with no problems...
     
  8. I found Racer lost focus if I had Firefox open. Doesn't happen all the time, but sometimes, and only when Firefox is running. Quitting Firefox & Racer then behaves normally.
    My old PC which my kids inherited runs Racer fine, C2D@2.8ghz, 4GB ram & GF9600GT 512MB, their PC gets at least 30FPS in Racer, mostly 60fps.
     
  9. Ruud

    Ruud
    RACER Developer

    I had the MS FF wheel once. The driver s*cked a bit in that it did busy polling, so it drags your fps down. The alternative would be to multithread the reading of the joystick (I do that with some exotic controllers, not wheels though), but as the MSFF is such an old wheel and the Logitech drivers don't do stupid things like really wait for the wheel communication before sending some state I guess I'm not too inclined to make it now for the old MSFF wheel. It sure was a nice wheel though, but the G27 is quite a bit better.

    As for the focus problem, some app apparently wants to have focus and switches to itself, hm. Any window come up activated? Anyway, try with all running applications closed. I see problems with OpenGL when you open Photoshop and/or Max at times.
     
  10. KS95

    KS95
    RACER Moderator

    If it wouldn't be too difficult, I'd sure appreciate whatever you can do to help. And iirc, there were others who posted with the same problem with other wheel's in the thread I had about this problem, maybe it could help them too? :)
     
  11. I want to make my first post on Racer's (newer) forum useful, and I figured out a solution.

    I had the same issue, but it stopped when I disabled Windows Aero. It can be disabled temporarily for Racer by disabling visual themes and desktop composition, by changing the compatibility settings in properties. This can work for other programs with a similar issue.

    To avoid the "run as admin" popup, you should do it for all users. There should be a button that lets you change that for Windows 7 at least.

    My specs are
    4 GB DDR2 @ 800 MHz RAM
    ASUS EN9600GT 512MB (almost the same as Nvidia counterpart)
    AMD Athlon II 445 X3 @ 3.1 GHz