1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

G27 Degrees of Rotation Not Staying

Discussion in 'F1 2015 - The Game' started by Kromey, Jul 14, 2015.

  1. Whenever I set the degrees of rotation in the global settings or f1 2015 profile settings in the logitech profiler, my g27 ignores it and goes to 900 degrees even if I did not allow the game to change the settings. When the profiler is maximized on screen, the degrees of rotation are correct, but when f1 2015 is maximized on screen, the g27 automatically goes to 900 degrees resulting in nowhere near 1:1 steering. Any ideas?
     
  2. Have you set your global device settings in the profiler to 360 deg and set all zeros in game advanced wheel settings?
    Only thing i can think of.
     
  3. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    My profile (in the logitech profiler) gets ignored, so I have deleted it.

    If you have profiles for other games, that fine just leave them alone.

    Try this :-

    Profiler > Options > Global Profiler Settings > Select 'Do not apply profiles to games automatically' > OK

    Then :-

    Profiler > Options > Global Device Settings

    FFB : 107% (or whatever you want)
    Spring : 0%
    Damper : 0%
    Enable Centering Spring but leave at 0%
    Rotation : 360 degrees
    Enable allow game to adjust settings

    In F1 2015 advanced settings, leave all sliders (saturation etc.) at the default 0%

    This means that when you play any game which does NOT have a Logitech Profile, the above settings will apply.

    For any other game, just select the profile you want to use.

    The 360 degree rotation and all sliders in-game at 0%, will give you 1:1 steering with the in-game wheel in your car.

    Cheers :)

    By the way, you don't need to use the Logitech profiler at all, if you don't want to. You can just use the setting above as your Windows default for your controller. Control Panel > Devices & Printers > G27 Racing Wheel > Right Click > Game Controller Settings > Properties > Settings

    But this will effect all games, if you are not running the profiler
     
    Last edited: Jul 14, 2015
    • Like Like x 1
  4. IVe deleted All profiles in profiler and set the wheel settings in game from the top @ 0, 23, 90. This gives me a 1:1 setup.
    Standard profiler settings are at 900 degrees
     
  5. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Codemasters have designed the system so that with 360 degree of rotation, and all sliders at 0%, the wheel is 1:1 and using raw input from the wheel,

    Your setting (900) has manipulated that raw input, so it's no longer raw, to effectively give you 1:1. This not a criticism, I'm just point out a fact :)
     
    • Like Like x 1

  6. This is one of the positives of this game for me, it actually works (for me).