• "Mwoah" - Kimi Räikkönen
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

G27 behaving badly

Discussion in 'F1 2010 - The Game' started by Paul Lock, Apr 15, 2011.

  1. Paul Lock

    Paul Lock

    Messages:
    2,837
    Ratings:
    +483
    Alright guys, wondering if this happens to anybody else...

    I expect like most people, when you first switch on your G27, its does its little calibration routine and the comes to rest. However, if I have my G27 turned on when I load up F1, it does a couple quarter turns, centres at the 12 o'clock position, but then starts rocking (kinda between 11 and 1 o'clock position) and doesnt stop until I grab it and hold it steady. If I give the wheel another little tweak, it will do it again.

    This doesnt stop the wheel working normally in game, and after a race, things are normal, even if I tweak the wheel it doesnt do this funny rocking.

    I dont remember it doing this before, and I cant think of anything ive changed. Doesnt happen when loading Dirt2 for instance.

    Anyone else experienced this?
     
  2. Jan-Olov Johansson

    Jan-Olov Johansson

    Messages:
    1,811
    Ratings:
    +182
    I have the exact same thing on my wheel, but I have a Logitech DFGT. Suspecting that it has something to do with F1 since it doesn't behave like this in any other racing game.

    Edit: It does not happend every time either so it's not easy to find out why...
     
  3. Viktor Andersson

    Viktor Andersson

    Messages:
    687
    Ratings:
    +22
    my G27 have starting doing this since 2 days ago in F1 ? I have never seen it before, but my wheel works as it did before the new rocking though.
     
  4. Paul Lock

    Paul Lock

    Messages:
    2,837
    Ratings:
    +483
    Well not that i wish problems on people, but I'm glad I'm not alone. I was worried it could have been the beginning of the end for my wheel!

    Maybe if any of us figure out what's going on we should update this thread.

    * with hind-sight maybe a mod could make my thread title more specific to the problem please?

    Cheers.
     
  5. Craig Whitmore

    Craig Whitmore

    Messages:
    240
    Ratings:
    +0
    You need to have no profile loaded and instead, configure the global settings. If you setup a profile for F1, then it does go jerky. The MOMO wheel does this too.

    If it still jerks, then reset global properties, that should remedy it. Also, turn down center spring that can cause it too possibly.
     
  6. Scott Webber

    Scott Webber

    Messages:
    7,392
    Ratings:
    +2,397
    It's normal Paul, i never use to have it but it started about 2 months ago.

    Just get use to it :p
     
  7. Michal Sochan

    Michal Sochan

    Messages:
    143
    Ratings:
    +0
    I have the same thing, but not often.
     
  8. ML2166

    ML2166
    If quizzes are quizzical then what are tests?

    Messages:
    4,188
    Ratings:
    +7,484
    Same thing here with my G27. Always happened, never known it not too.
     
  9. Craig Whitmore

    Craig Whitmore

    Messages:
    240
    Ratings:
    +0
    My G27 does not do this, as I do not load a profile for F1, I leave it set to default profile.

    You have to have the Global Device Settings being used for F1 and not use a profile.

    Settings that I use are:

    Overall Effects strength 94%
    spring effect strength 0%
    Damper effect strength 0%
    enable center spring in force feedback games = Checked ON
    center spring strength 0%
    Report combined pedals = checked OFF
    degrees of rotation 200%
    Allow game to adjust settings = checked ON

    If you have a profile for F1 2010, delete it.

    If it still is a problem, reset both Global device settings and Global profiler settings.

    This fixes the issue for me, My G27 does not do perpetual left to right to left etc jerky stuff. If I pull the wheel to one side and release, it settles in the middle.

    I hope this fixes it for you. I have had this issue before and it has always fixed itself when I did the above process. You do not have to have the first 3 settings at 94%, 0% & 0% though. If I set the center spring %age, the jerky effect starts to happen in proportion to the center spring %age.
     
  10. NoobBlaster

    NoobBlaster

    Messages:
    36
    Ratings:
    +0
    I had this problem with my DFGT wheel but I pushed the global FFB setting to 150% just for an experiment. I learnt never to go past 100% lol!