1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

fraps help

Discussion in 'F1 2011 - The Game' started by kbaum, May 14, 2012.

  1. for some reason when im playing f12011 and decide i wanna record something i start up fraps... then it seems like my steering wheel just will not work, and its really frustrating... close fraps and it works again.
     
  2. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Wow!

    I've never heard of such a thing before, and I have used Fraps for years. I just can't see how fraps hooking into the game can effect the wheel.

    I suppose that if it was me, apart from updating fraps to the latest version (if you haven't already), is to look at your USB setup or gaming software.

    Do you have other USB ports you can use? If you do, try the wheel in another port.

    Perhaps it's also worth going to your control panel > device drivers, and un-installing ALL the USB hubs/controllers listed. After doing this you would then reboot your machine and Windows will automatically re-install the usb port drivers. This ensures that you don't have a corrupted driver somewhere

    You don't mention what wheel you are using, but if it's a Logitech one for example, make sure you download the latest driver/software from the Logitech website.

    Consider un-installing and then re-installing the software for your wheel.

    Have you tried any alternate capturing software? Even if you don't intend to buy other software, they usually have demo versions you can test. Try one of those and see if the problem persists.

    My favourite capturing software is currently DxTory (www.dxtory.com), you could give that a try. I find that it doesn't overload the system too much, I can capture to the exact resolution I want, rather than 1/2 screen, 1/4 screen etc.

    Another big advantage for people like me who have multiple hard drives, the program can share the load. You can select a special raw capture mode that stripes the video across the drives (a bit like a RAID array). You can select as few (2) or as many drives as you want to use. So one frame goes to one drive, the next frame goes to the next drive and so on .... Less chance of one drive 'choking' on you.

    Anyway, I am going off-topic a bit now, so I'll leave you to it, and wish you luck :)
     
  3. Yeah Ive not heard that one either.

    Maybe before trying the good above advice from Gnu, just a quick thing to try, change the record button which Fraps uses to something else. Im just wondering if there is a conflict of some kind with the button and some wheel function perhaps. (you havent mentioned which wheel)

    Maybe a long shot but this is a weird problem! Alternatively, dont load Fraps, go into F1 2011 and press the record button and see what happens to the wheel. If it goes weird without Fraps running, then you know its not Fraps related.
     
  4. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Good point, because I was assuming that when he said 'start up fraps', he meant just running the program causes the wheel not to work, rather than when capturing the wheel doesn't work. (So a hotkey was used)

    As I have said, I have never had issue with fraps and this game, apart from load it can put on your system, and I also didn't like the 4gb file splitting. In the latest fraps the file splitting is optional.

    On a side-note:

    The one piece of software that DOES interfere with this game is Playclaw, which was my previous favourite program. Playclaw 2 was fine, because you adjust ALL your capture settings via your desktop. In the new Playclaw 3, they use a game overlay hook. Basic settings are done via the desktop, but most settings are done whilst in-game, using a menu overlay. Once you invoke the hotkey for the overlay, F1 2011 will go wild, randomly stepping through the menu system very quickly, and selecting random menu items. It's quite disconcerting, but nothing bad has happened yet. You do your settings (very) quickly, then turn off the overlay menu as soon as you can.

    This is what led me to DxTory .......
     
  5. Ah yeah, you might well be right mate! Re-reading it, he does say 'close fraps' rather than 'stop capture'.
     
  6. I have a logitech G27 wheel. My capture button is A. Its just a weird situation. I was in a practice session and wanted to record my lap to compare it to real laps. So i load fraps minimize it and go back to f1 2011. I hit "a" to record. I make it through turn 1 fine but as soon as i am going to hit turn 2 my wheel just doesn't turn in game even though i have my physical wheel turned to the left. (thats what the video below shows) If i run fraps and then start f1 2011 my wheel in game will not turn at all even though my physical wheel is turned. i have to completely restart my game to get my wheel to actually turn

    Video...
     
  7. Have you tried MSI Afterburner? I' currently using that to record all my games. It's free and works like a charm :) Only thing I'm using fraps for now is screenshots and FPS.

    Another thing is MSI Afterburner only writes to 1 file (size seems to be smaller too) instead of Fraps that keeps creating seperate files for one session.

    Hope this helps?
     
  8. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    The lastest FRAPS does not split the files in to 4Gb chunks, unless you deliberately set it up that way, they have kept the option for legacy support.

    It has taken them far too long to get rid (by default) of the file splitting. It was there because of the limitation of FAT 32 formatted drives, but NTFS has been the norm for donkey's years now. Their refusal to do this long ago (many requests from users) is simply just lame.

    As I said in my first post, have you tried other capturing software? As Tiens said, have you tried Afterburner, it's free. Also there is free capturing software built into XFire (xfire.com). Even the payware software usually has a demo version. You need to eliminate things when fault finding to try and reduce the possibilities.

    Use the same capture hotkey whatever program you use, and try not to use any key that the game uses by default for another function. For instance you are use the 'A' key, which happens the be the in-game 'gear up' key when using the keyboard. Personally I use Function key F11 with no problems.

    As you use the G27 (So do I), have you downloaded and installed the Logitech Profiler software? It's not strictly necessary, as the game's actionmap file for the wheel should work alone, but it's worth having.

    http://www.logitech.com/en-us/441/5184?selectedcrid=441&selectedcid=5184&osid=&bit=

    If you do have it installed and running from boot (the default), have you tried closing it down, to ensure it's not effecting the game in any way?

    So essentially :-

    1/ Run the game and use fraps with the Logitech profiler running. (Current situation?)

    2/ Run the game and use fraps with the profiler NOT running

    If item 2 fixes it, then the profiler is at fault. No difference at all, go to 3

    3/ Download and install any other capture software, set it to use the same hotkey as you use in fraps. Run the game and capture a video sequence.

    Is it OK now? If it is, then fraps is at fault.

    Ensure that you have downloaded and installed the latest fraps, which is always free to those that bought it. Currently 3.5.3

    Whatever happens FRAPS is not your only choice, and IMHO is not the best choice (even though I bought it), I rarely use it now.
     
  9. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Other thoughts.

    1/ Have you tried the wheel in a different USB port yet

    2/ Is the USB port you are using connected directly to the motherboard, or is it an extended hub?

    3/ If it is an extended hub, is it powered? (have it's own power supply).

    4/ If it's not powered, is there too many powered items attached?

    5/ Please tell me you not trying to capture to a USB hard drive, especially if the wheel is connected to the same hub?
     
  10. @Gnu UK very good points there.
     
  11. i have tried other software and fraps is the only prpgram that records smooth... every other program i used just looks like its a slidesow of photos and has no sound atall, also i have fraps paid for. i have tried all 4 of my usb spots in the back.. i only have my keyboard, mouse and wheel hooked up via usb. fraps screws with the wheel every time. i dont use a hub. i plug directly into 1 of the 4 ports in the back of my pc.

    Programs i have tried
    fraps --- the only program that actually records, but screws with my wheel
    dxtory --- records and pays back like a slideshow
    xfire --- cannot video record at all, cannot find a correct tutorial to show how
    debut professional --- records and pays back like a slideshow
     
  12. and i have the profiler, as i used the same exact wheel for iracing....

    system specs(i just built this system 4 months ago)

    Windows7
    MB ASROCK|990FX EXTREME3 990FX AM3+
    SAPPHIRE HD6850
    PSU CORSAIR|650W CMPSU-650TXV2 R
    CPU AMD|PH II X4 975 3.6G AM3 %
    G-Skill 4GB RAM
     
  13. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    I am running out of ideas.

    Does fraps work ok with the wheel in iRacing?
     
  14. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

  15. im not sure.. i havn't had my subscribtion renewed since ive been playing f1 2011. ill try fraps with Dirt3 tom, and let you know
     
  16. tested it in dirt3. fraps worked, and the wheel worked. i changed the capture key to NUB DEL for dirt3 trying that in f1 now
     
  17. nope in f1 2011 it still cuts the steering off... as soon as i hit the capture button though something defently happen in the background because my cursor went to the loading cursor
     
  18. msi afterburner works. thanks!
     
    • Like Like x 1
  19. Glad to hear it works for you :)
     
  20. Graham Laing

    Graham Laing
    ...... mostly harmless Staff

    Yes, glad to hear that you've got something working.

    It's certainly a strange fraps problem. The only other thing I would mention, is that it would be preferable to have any virus checker disabled when capturing. This is to prevent the newly opened (for writing) capture file from being scanned by the virus checker whilst it's still being created.

    Although some virus checkers have the option to disable the 'on file access' function, or for it to ignore a specific folder or folders.

    Anyway ...... enough of this, get some racing in! ;) :)