1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

FPS / GPU driver question

Discussion in 'Stock Car Extreme' started by mkel1966, Oct 28, 2015.

  1. Hi...sorry for this noob question, still new to pc gaming adjustments and all.
    I just updated my graphics card driver to 358.50-win10-32bit(latest from nvidia thru geForce Experience) and my fps on GSCE and beta version mostly on full is playing between 54 to 61, mostly on 60 fps and never goes up. The previous driver, 353.62-win7/8/vista-64bit, with the same settings is between 143-180 fps sometimes higher. Should I revert back to the previous version?
    System: MSI GTX 970 on i7-4790k
     
  2. Check to see if vsync is on.
     
    • Like Like x 1
  3. Kurupt CDN

    Kurupt CDN
    Touring car fanatic Premium Member

    Vynsc is enabled either in your nvidia global settings or ingame
     
    • Like Like x 1
  4. Warren Schembri

    Warren Schembri
    Premium Member

    Maybe you should down the 64-bit version of the driver?
     
    • Like Like x 1
  5. Kurupt CDN

    Kurupt CDN
    Touring car fanatic Premium Member

    You have listed 2 nvidia drivers for 2 different operating systems. Find out what os you have installed on your pc ex. Win 10, win 8, win 7 or Vista than check if your using 32 bit or 64 bit. Once you figure that out, look for the newest nvidia driver that matches your pc os .
    You should be running this game in the 100-300 fps on your system for a single screen as I have an older i7 2600 with 970 ssc and 3440 x1440p monitor using nvidia inspector to over ride the AA setting using 4xs + 4x sparse grid and I get between 80-120 fps
     
    • Like Like x 1
  6. Thanks guys,,somehow the vsync was on "adaptive" in nvidia control panel. I think the new driver works better because i have my previous fps back with everything on full and shadow blur 'on'.:thumbsup:
     
    • Like Like x 1
  7. Thanks for this. I forgot to check I am on 64bit. All good now.