• "Auto racing began 5 minutes after the second car was built." - Henry Ford
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

FPS drops in recent update of either Windows, nVidia or AC.

Discussion in 'Assetto Corsa' started by Carlitox, Oct 19, 2017.

  1. Carlitox

    Carlitox
    Premium

    Messages:
    48
    Ratings:
    +83
    Hello all. Apologies as I'll bother you with a technical question :D

    As the title says, recently I've been experiencing bad FPS drops in AC. I normally hotlap on my own and race on club events. Haven't raced in a while though, so the rig hasn't had to render a full grid for a while now.

    Very recently, the three aforementioned things updated for me: Windows 10 (update KB4041676), nVidia GeForce drivers (version 387.92) and AC itself (the latest update for the Ferrari DLC). In the past few days I've noticed drops from stable 60fps (I actually have it locked there to prevent tearing) to 28-30fps in some tracks and in some camera angles, but most severely on replays. Before, I only had drops in select zones in the Nordschleife, which I knew well and expected. But now all the circuit is unstable. Other less cluttered circuits don't lag when I'm driving, but they do when I'm on a replay.

    I tried rolling back the GPU drivers to no avail. I can't really roll back AC and Windows is a lost battle. I'm glad I didn't get the BSOD that many other users had.

    So my question is basically if anyone has had any similar issues and any advice is greatly appreciated. :)

    Onto the specs then. My PC is a Core i5-4590 @ 3.3ghz, GTX 970, 16gb RAM DDR3-1600. My settings are as follows:
    [​IMG]

    Thanks a lot in advance!
     
  2. RasmusP

    RasmusP
    AC Stuff and G27 help Staff Premium

    Messages:
    2,099
    Ratings:
    +784
    Hey man, I'll give you a quite short reply and a longer if you need further support :)
    The first thing to do in such a case is to see what's bottlenecking. You need some hardware monitor!
    I would recommend open hardware monitor (just Google it) or msi afterburner (bit more complicated).
    You need to find out your gpu and CPU loads in the moment of the fps drops.

    What you can try first: for some reason anisotropic filtering (AF) is heavy in ac so even with a 1070 I put it to only 8x!
    The other thing, especially since it's only active in replays is to disable DoF. :)
     
  3. Carlitox

    Carlitox
    Premium

    Messages:
    48
    Ratings:
    +83
    Hi Rasmus and thanks for the tips!

    I'm testing now, looks like DoF was the one killing the replays. I already had Afterburner installed, and I did notice that the worst drops were in wide shots where you see the landscape and the DoF effects are all-out. Getting rid of that stabilised the FPS. For the drops while racing, what I did was reduce the shadows a bit, because the GPU would load up while going through dark sections. One example is the Nordschleife after Aremberg, that's the only part of the game where there's a drop I could never mitigate, so I've come to terms with it :) The drop is still there, but the rest of the track works fine. Didn't need to reduce AF, but since 8x wasn't really that different from 16x on a 1080p standard monitor, I did it anyway.

    So far, the places where it used to drop to 28fps still drop but are barely noticeable. As per AC's app, they drop now to 55fps, so it really is OK. What bugs me is that DoF and the shadow quality worked just fine until recently, in fact I haven't adjusted the graphics since I bought AC. Either the Windows or the nVidia update broke that option for me.

    Anyway, it works nicely again, so big thanks Rasmus! Looking forward to returning to some club races as soon as I free myself up.
     
    • Love Love x 1
  4. RasmusP

    RasmusP
    AC Stuff and G27 help Staff Premium

    Messages:
    2,099
    Ratings:
    +784
    My bet is on the windows update by the way. A few threads popped up, all having problems with the new update.
    AMS anti aliasing broken, ac not launching, ac launcher freezing etc etc :(
     
  5. Billy Pilgrim

    Billy Pilgrim

    Messages:
    692
    Ratings:
    +105
    A few months ago there was a Windows 10 update that amost halved my fps.

    I undid the update ( which was easy to do) and that totally fixed it
     
  6. Terry Rock

    Terry Rock

    Messages:
    1,066
    Ratings:
    +359
    I just did the Windows10 version 1709 (build 16299.19) Creator update on Saturday and it does indeed have a bit of a stutter at certain parts of gameplay in AC.
    It's not constant throughout...but it is there for a few micro seconds during gameplay.
     
  7. JuanBonX

    JuanBonX
    Web design Premium

    Messages:
    226
    Ratings:
    +57
    Hi, I have Window 10 Build 1709 and as always you have to follow many steps to optimize it.

    in Window there are certain factors that affect the performance in games. If you leave the active window updater always in the long run you will end up with the slow system and fragmented registry.

    Other factors that affect performance are unneeded services and programs in the background while you're playing.

    If you played well with the same configuration that now gives you trouble, that is not the case.

    Check if the configuration of the INVIDIA control panel is correct.

    This is the one I always use. No need to edit anything else.

    [​IMG]

    The anisotropic filtering should always be at x16 in the game settings if you want decent quality textures.

    If your video card allows you to raise the core frequency and memory much better. (Overclock)

    example:


    [​IMG]

    Regards,
     
  8. Jarqus

    Jarqus

    Messages:
    49
    Ratings:
    +7
    Try turning off the inbuilt Game Mode (as I dont believe you can turn if off any more with a tick of a button)

    Go here

    HKEY_CURRENT_USER\Software\Microsoft\GameBar
    look for a key called AllowAutoGameMode
    change the value to 0

    as others have said they noticed strutting with game mode on vs with it off

    edit I also notice my nivida install was not in the add remove part.

    So I used DDU removed old drives and reinstalled new ones

    I would also turn the reflection frequency down a little. No noticeable while racing anyway.
     
  9. Jarqus

    Jarqus

    Messages:
    49
    Ratings:
    +7
    And I suggest to use a program OOshutup10. Not really a performance thing. But disables many many many MS logging/tracking and stuff
     
    • Agree Agree x 1
  10. Stig Bidstrup

    Stig Bidstrup
    Jarek Says- "900 degrees of rotation" Premium

    Messages:
    1,253
    Ratings:
    +931
    After latest Nivida drivers update ( same as you 387,92 ) I have also had a FPS drop, I use windows 7
     
  11. Terry Rock

    Terry Rock

    Messages:
    1,066
    Ratings:
    +359
    Thanks for the response.
    I found the source of my hitching issue just after posting.
    When right-clicked my desktop to launch the Nvidia C/P, the option wasn't there....completely missing.
    The Creator 10 migration seems to have 'duffed up' my official Nvidia driver install.
    On downloading and starting the install of the 388.00 driver (released on 10/23), setup reported no current driver installed.
    The hitching was gone after installing the new driver on first run of AC.
    The framerate is actually up a bit, at between 130-145 with all option set to high and most apps turned on.
     
    Last edited: Oct 25, 2017
    • Like Like x 2
  12. JuanBonX

    JuanBonX
    Web design Premium

    Messages:
    226
    Ratings:
    +57
    I recommend playing with the vertical sync activated. Regards
     
    • Like Like x 1
  13. guidofoc

    guidofoc

    Messages:
    188
    Ratings:
    +104
    As I wrote in another thread, if I press Alt+ Enter while in drive mode the game now enters in 'real' full screen and is fluid again, that's what I am seeing recently. So maybe this is not related to your issue but try also with Alt+Enter.
     
  14. Martin Fiala

    Martin Fiala
    Premium

    Messages:
    1,735
    Ratings:
    +1,874
    Game Mode is disabled by default, you have to specifically turn it on for a given game. As for Game Bar, you can turn it very easily in the Gaming app in the settings. No need to mess with the registry.