1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

FFB dissapeared after adding a brake load cell

Discussion in 'rFactor 2' started by Larry Thomas, Jun 2, 2012.

  1. This morning I added a brake load cell to my G27 pedals. The problem is that I no longer have any FFB on the wheel. I tried rF1 and GSC and the FFB is working normaly so it seems to be a rF2 problem. Tried changing some values in the controller.ini but have not had any luck.
    So if anyone has any ideas would greatly appreciate it.

    Just tried resetting the wheel (turn left and turn right) and it is reversed!! ie, to set the wheel "turn left" I had to turn the wheel towards the right!! Could be related?
     
  2. Knut Omdal Tveito

    Knut Omdal Tveito
    Premium Member

    @Larry Thomas
    Have you reassigned the wheel? There is a "Detect" button in the controls menu for that. I've seen people having problem if they assigned controls and not using the Detect function.
     
  3. Tried that Knut but didn't work. Thanks for your suggestion.
     
  4. Knut Omdal Tveito

    Knut Omdal Tveito
    Premium Member

    Hmm, a bit weird that it works on the other sims. Still, you can try to switch USB port to reset the previous calibration (and then re-calibrate in Logitech software and re-detect wheel in rF2)
     
  5. Didn't work either :(. Thanks for the suggestion though.
     
  6. Knut Omdal Tveito

    Knut Omdal Tveito
    Premium Member

    Did you update from build 69 or did you make a clean install?

    I also have a G27 with load cell and this is what I did. With my old build 69 install I went to mod-manager and uninstalled everything, also the ones that are listed when I un-tick "show only mods". Then unistalled the game, and installed build 85_full and reinstalled all mods. Everything is working fine for me now.
     
  7. Marco Bijl

    Marco Bijl
    adMAXIhater (O.O.O.)

    Do you perhaps have more controllers installed on your PC? Gamepads or something/ There is a limitation on nr of USB devices rF2 can use. Might be that's a problem as well?
     
  8. Marco, I only have the G27 and everything worked up until I added the load cell. So i do not think that is the problem.

    Knut, I think I need to do as you suggest as nothing else I tried works. Will uninstall completely and reinstall the the full 85 build.

    Once again thanks very much for your ideas Knut and Marco.
     
  9. Marco Bijl

    Marco Bijl
    adMAXIhater (O.O.O.)

    There is 1 more thing to try first Larry,

    Open your Windows Explorer
    Go to the data folder of your install
    Go into the USERDATA folder
    Go into the PLAYERNAME folder
    You should have a folder controllers there. Look for the G27 custom file, and delete it.
    Now go 1 folder back up
    open your player file

    There is a line in there which identifies your controller, and it should be on the custom one. Replace that with a default controller name

    Now open the game again and try to set the controller to the custom one again.

    If that fails, then a reinstall would be the best option I think.
     
  10. Didn't work either Marco:cry:.
    So, have uninstalled, deleted everything and am currently downloading. Here's hoping....
     
  11. Marco Bijl

    Marco Bijl
    adMAXIhater (O.O.O.)

    To bad. lets hope reinstall will fix the issue for you then!
     
  12. Didn't work. :poop:
    Next step; the profiler.
     
  13. Marco Bijl

    Marco Bijl
    adMAXIhater (O.O.O.)

    And? Did the profiler make it work?
     
  14. Haven't tried yet Marco. Will give it a go next week end when I get a bit more time.
     
    • Like Like x 1
  15. Reinstalling the profiler did not work either.:mad:
    Am completely lost about what I can do now.:confused:
     
  16. Knut Omdal Tveito

    Knut Omdal Tveito
    Premium Member

    @Larry Thomas
    Oh this was a tough one! I thought the reinstall would clean things up. If you want to try another re-install I would suggest the following (I just did it on my PC):
    • In mod-manager uninstall all mods.
    • Go to Packages folder and move your files to a safe place so that you don't have to re-download.
    • Uninstall rFactor2. Check both Core and Data for uninstall.
    • Restart computer
    • Manually delete all remaining content inside the rF2 Data folder and rF2 Core folder.
    • Install rF2. Do not install in the Programfiles folder. I use C\rf2data for the data files and C\rfactor2 for the core data.
    • Before you install the mods check if the steering wheel is working.
    BTW what do you see when you hit the detect button? Does it say G27 Racing wheel USB etc.. or something else?
     
  17. Got the FFB back :D Not quite sure how but is related to the Logitech profiler. Will check it out tomorrow. For now I am off to bed.:sleep::sleep::sleep:
    And Knut, the detect button picks out the G27 correctly.
    Thanks for your ideas guys. Appreciate it . :thumbsup: :thumbsup:
     
    • Like Like x 2
  18. When I set up the profiler I go into "parametres specific to the game" (not sure what it exactly is in english). I completly ignore the "Global parametres".
    It turns out that rF2, at least in my case now, takes the "Global Parametres" and not the "Specific game parametres". And in the "Global parametres" the "Combined Force Effect" was set on 0%! Why or how I do not know.:unsure:
     
  19. Marco Bijl

    Marco Bijl
    adMAXIhater (O.O.O.)

    Not sure about that as well.. Just glad you fixed it :)
     
  20. Knut Omdal Tveito

    Knut Omdal Tveito
    Premium Member

    I think the game-specific settings only work if you launch the game from the profiler (i.e. the links on the side saying "Play GameX"). If you start rFactor2 from the normal shortcuts it uses the Global parameters I think. Glad you worked it out Larry:thumbsup: