• “Just being a mediocre driver has never been my ambition. That's not my style” ― Michael Schumacher
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Have a chance to win a copy of F1 2017 The Game (PC) by following RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and / or YouTube.

Fanatec CSL Elite pedals w/o LC

Discussion in 'Sim Racing Hardware' started by BBKing212, May 21, 2017.

  1. BBKing212

    BBKing212
    Premium

    Messages:
    174
    Ratings:
    +174
    Hi,

    I've got new pedals (approx one month old). Few days ago I've noticed that I have dead zone on throttle and on brakes.

    On throttle I have dead zone at the beginning of the pedal travel and at the end (check attached diagram). Red line represent the whole pedal travel. Blue line 1 represents where actually throttle activates and blue line 2 represents where throttle "thinks" that it reached its maximum travel.

    This behavior is same in R3R and in AC.

    Any help would help :)

    Thank you!

    P.S. Pedals are connect to computer via Fanatec USB cable converter.
     

    Attached Files:

  2. Ben Cobbé

    Ben Cobbé
    Premium

    Messages:
    54
    Ratings:
    +16
    Did you recalibrate the pedals using the Fanatec tool?
     
  3. BBKing212

    BBKing212
    Premium

    Messages:
    174
    Ratings:
    +174
    Yup! Same thing there!
     
  4. David O'Reilly

    David O'Reilly
    A bad quali means I can go forwards in the race. Premium

    Messages:
    7,313
    Ratings:
    +6,170
    I had this issue on my old CSR pedals.
    It might be the same. (faulty potentiometers)

    You can try using a tool called I think DI tweak.
    It can adjust between the pedal output and the PC input.
    Free and not hard to use.

    Edit; called DIView and there is also DI Tweak.
    I think I used the first.
     
    Last edited: May 23, 2017
  5. BBKing212

    BBKing212
    Premium

    Messages:
    174
    Ratings:
    +174
    Since the pedals are still new, I've opened a support case at Fanatec. I will let you know how it goes.
    Thank you all for the help!
     
  6. Frans van der Linden

    Frans van der Linden
    White Knockels Simracing Premium

    Messages:
    559
    Ratings:
    +131
    Any answer yet?
    I have same problem in Automobilista...
    Undriveable like this ;-(
     
  7. BBKing212

    BBKing212
    Premium

    Messages:
    174
    Ratings:
    +174
    So I've opened a support case at Fanatec and they instructed me to send them over and I did. To recap, according to Fanatec, deadzone is expected in pedals without LC. Bellow is their response/statement regarding dead zone in CLS elite pedals without LC:

    " after discussing about your case with my supervisor and checking many other brand new CSL Elite pedals, I can confirm you that a bit of dead zone (around 15mm - if using the black flat pedal stop). As already mentioned in my previous email, to avoid any dead zone at whole, you would have to upgrade them with the LC. By using the LC kit motherboard, you would have a digital signal that can be perfectly manually adjusted in the driver."
     
  8. MegamanAT

    MegamanAT
    Premium

    Messages:
    125
    Ratings:
    +63
    Fanatec quality... Do you have a Fanatec base? Otherwise I would get a set of T3PA-Pro. That's what I will do, whenever my csr-e fails the next time. won't spend any more money on spare parts.
     
  9. Frans van der Linden

    Frans van der Linden
    White Knockels Simracing Premium

    Messages:
    559
    Ratings:
    +131
    @BBKing212
    I have the CLS Elite Pedal LC

    And i had same problem...
    Only in automobilista!!!

    i had to re-assign the pedals in game. then it worked perfectly
    maybe it works for you too ( if you still havend fixed it )
     
    Last edited: Sep 16, 2017