1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

F1 2011 crash

Discussion in 'F1 2011 - The Game' started by Merkieman, Oct 20, 2011.

  1. So just today when I was about to play F1 2011, I just clicked on the game and it looks like it's about to load from steam, it just crashes, the stopped working message comes up and I don't even get the black loading screen.

    It did work before, don't know what would've caused this, is it possibly some sort of new patch, I doubt it because my steam is set to auto update games.

    My system specs:
    AMD Phenom II X6 @ 2.80Ghz
    4GB DDR3 ram
    windows 7 64 bit
    ATI Raedon HD5750
    I think that's all you need to know, i doubt it's got anything to do with my specs but I posted them because of the possibility

    I don't want the bloody money wastednow I need a fix for this, please someone, before I get truly pissed off

    It MAY be an issue with the software I'm using that detects my ps3 controller which I use for the game. But I have some sort of Issue where it comes up with Bad image and then says sensapi.dll, someone please help I want to play this game big time

    Someone else has got to of had this crash, anyone know how to fix it without uninstalling/reinstalling (Thanks to slow net).

    My game is from Steam and I can't even reach the black loading screen without a crash
  2. Try this:
    1. Clean all GFWL profile directories
    2. Uninstall WindowsLive-ID
    3. Uninstall Games for windows live
    4. Uninstall net framework
    5. Then download Games for windows live and install it

    It resolved similiar issue that i had with f1 2011
  3. I reinstalled games for windows live and it says that a component needed is not enabled

    way to fix?
  4. It doesn't load because it says a required windows component is disabled on this machine
  5. live-id ?
    .net framework?
  6. I reinstalled the game, I've got the .net framework and I try to install GFWL and it doesn't install because it says I don't have the administrative rights? What ? This is the only account on my pc and it's an administrator one, someone please help i want to play this game, can't cos xlive.dll missing due to the fact that gfwl wont install for the reason above

    Someone help, im not going to give up on fixing this, its the windows live sign in assistant, i will be very greatful if someone can help me here, i've tried and tried



    The message I am getting when I'm trying to install GFWL is service " Windows live ID sign in assistant' (wlidsvc) failed to start. Please verify you have sufficient administrator priveleges to start system services.

    I AM the administrator
  7. I had this problem with dirt 3. Solved it with next steps:

    Uninstall Microsoft Games for Windows Live from the Windows control panel.
    Delete the following folder: C:\Program Files\Microsoft Games for Windows - LIVE. (or equivalent on other drive)
    Now re-download the latest GfWL client here.
    Reinstall this new client.

    For youre error over admin rights. Try right mouse on exe file and choose run as administrator
  8. The thing is, I don't even have it installed, because this step in the downloading/installing procedure fails. It's the windows live sign in assistant, and even if I try to start up f1 2011 it says xlive.dll is missing, due to this.
    That folder doesn't exist.
    Where is the latest gfwl client, was that meant to be a hyperlink?

    Ah the irony, games I love that are the hardest to run

    The reason as to why I'm double/triple posting is because I want this game working and I want to PLAY it, which is why I did buy it, please I will be very greatful, I got f1 2011 off steam too

    Anyone help, someone else has got to have had the same problem

    The whole problem is here that I cannot install the windows live ID sign in assistantdue to insufficient administrative priveleges which I have, cos im th eonly admin on this computer, its mine...

    anyone can help?
  9. There are a few things you can try

    You can enable the build in administrator account. Set a password for the account. REboot pc, log in with administrator. Then maybe remove your own account for admin group. Apply (maybe even reboot), log in with admin account and make your own account again member of admin group.

    Did you delete the windows live folder in program files. Because sometimes, windows have a problem then with install in same folder if you dont delete it.

    You can always check if the folder is still accesable with admin credentials. If not, take owner right by going to the properties of the folder.

    Did you download latest games for windows live from microsoft?
  10. The thing is, I don't even have the whole windows live thing installed, because my computer won't let me install the windows live id sign in assistant because it says I don't have the priveleges, even thoguh this is the only account on this computer, which is an administrator obviously. I don't have the windows live folder.

    It is my computer not letting my install the windows live id sign in assistant that is causing the problem here, because it says I don't have the rights.??

    Please help and reply back, I've waited patiently and I'm so eager to play this great game
  11. This might not be related but i can no longer play co-op with my friend, whenever we invite each other in our game just crashes and we have tp restart our xbox's. It works fine when we invite each other to a normal multiplayer lobby but on co-op it just freezes :(
  12. Yeah but I can't even get the game running, I don't go into any black screen i click on the executable and it brings up an error due to my PC not installing the windows live id sign in assistant, someone please help

    im going to keep posting here till someone knows how to fix, I payed for the game so I should be abl eot play it
  13. Try this

    have you tried installing GFWL and run it as the administrator? when you are asked to install click the right button on your mouse and it will say run as administrator click on this as yes. let us know how you get on? try uninstalling old GFWL first and look for the latest version
  14. GFWL isn't even installed, because windows live sign in assistant won't install properly due to it saying It wont run because it says i dont have the admin rights even though my account is the only admin account on the computer.

    This is games for windows marketplace.
    There is no windows live folder or GFWL in the add/remove.

    Thanks for you help though, I hope someoen can help me find a fix here.
  15. I had awful trouble with this game. I kept re downloading the game and the deleting and re installing GFWL.

    Eventually I changed my anti virus from AVG to Microsoft Security Essentials and it worked

    Don't know if this will help you.


    Mike Oilseal Cooper
  16. Strange, what does changing your antivirus to microsoft security essentials have to do with the game getting to run, other than it being from microsoft, I used avg too, but i changed now
  17. Select file with Right Mouse Button and use "Run as Administrator"
  18. I've Done that already about 15 times

    I'm extremely pleased to say that thanks to my strong will to get this fixed I finally have.

    Fix is C:/Users/yourusername/Appdata/Local/Microsoft right click on GFWL file and click Take ownership.

    and voila, thanks to all who tried to help