1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC Experiencing a performance boost after todays Nvidia driver update?

Discussion in 'Assetto Corsa' started by Greg Latty, Jan 22, 2015.

  1. Maybe its just me but after todays driver update, im finding the game to run a lot smoother. Previously I couldnt run the 20 car urd egt career race with out insane stuttering. But now I can run it at a stable 60 fps (vsync on) with barely any hiccups and even bump up some of the settings. The release notes indicate there are some dx10/11 fixes. Could this be why?
     
  2. What video card and OS version do you have? Sometimes the changes are more sensible on newest card models.
     
  3. Windows 8.1 and gtx 780 SC acx cooled
     
  4. I think it is more of an placebo effect tbh.
     
  5. Could be. But even advanced warfare runs a helluvalot better for me
     
  6. There have been similar reports elsewhere so there may be more to it.
     
  7. Is this with v347.25?
     
  8. yep
     
  9. I can report better smootness and more ai car too
     
  10. My uneducated guess would be it has to do with the dx10/11 optimizations mentioned in the changelog
     
  11. Good info, thanks all. Remember tell your OS and card model as for some models it may not reflect better performance, on some cases it even is worst.
     
    • Agree Agree x 1
  12. How do you tell them??
     
  13. Joao Alves

    Joao Alves
    Premium Member

    Win 8.1 Pro 64-bit with 2x 760's in SLI. Getting The same frame-rate I was before, but a lot less stutters. I was getting some serious lag when going over aggressive kerbs for whatever reason, and that seems to have gone away altogether now.

    Maybe a nice little SLI boost hidden in there somewhere, since it's a smoother overall experience.
     
  14. Mate I got 2xGTX580 and running SLI, a lot less stutters to, I don't know if I have Sli setup properly and also the sli settings for NVidia Inspctor, could you help me out and maybe tell me how to set up properly or post screenshots of you NVidia inspector profile??
     
  15. My sidescreen produce decent colors again so i'm happy!
     
    • Agree Agree x 1
  16. Joao Alves

    Joao Alves
    Premium Member

    So the only thing you have to do to configure SLI is to go into the NVIDIA control panel and set it to 'Maximize 3D Performance'. So it should look like this when you're done:
    [​IMG]
    And as for NVIDIA Inspector- I'd love to help you with it, but I don't actually use it. And if I can make a humble suggestion; don't use it unless you know precisely what you're doing as just one wrong setting can potentially ruin your performance completely.
     
  17. Cheers
     
  18. At first I thought that the new drivers gave a big boost in fps but as soon as I noticed the jaggies on screen I realised it had turned SGSS off in nVidia inspector...

    So, no difference for me compared to previous drivers. (GTX 780Ti)
     
  19. Didn't notice a difference in fps but I did some testing with the PP settings. It seems like it's what is causing the shuttering. It also happens when going over kerbs like others have mentioned. Turning off PP effects fixes it for me.