1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC ERROR: No tracks available..

Discussion in 'Assetto Corsa' started by Nobby76, May 30, 2014.

  1. Hey guys.
    Im hoping someone here can help me out..
    Im getting a problem involving tracks.
    I have several custom tracks already added and the game worked fine. Tonight i added another 4.
    When i load Assetto i get an error pop up
    "Error: No Tracks Available"

    And as it says, when i go to the track select screen i have no tracks, not even the official ones. All the tracks are in the correct place "assettocorsa/content/tracks/*track name*

    Anyone know whats going on ?

    SOLVED: See This post for the solution.
    Last edited: May 30, 2014
  2. I've had the same problem, remove one or both of these tracks - Roadamerica and/or the nordschelife by snoopy.
    If that doesnt help, remove all custom/modded tracks. Try to start the game. If successful, add one custom track to the library at a time - when the error reapears, you found the culprit.
  3. yeah i just came back to report . id removed all custom tracks and started the game and everything was fine again.

    I have A Nordschelife, not sure who it is by, but i was racing aorund on that track last week... but Road America was one of the tracks i added tonight. so i shall add all others but those 2 and see what happens.. i shall report back.
  4. ok i just went through them 1 by 1.
    For me, it turned out that the Top gear track and Champions Motell are the tracks giving me problems. Although a few days ago i was driving about on the top gear track.... Might try redownloading them see if that does anything..

    Also, both Road america and nord seem to be fine on my computer..
  5. OK now i know whats going on...
    If you get a "No tracks available" Error. It is probably a mistake in that a tracks "ui_track.json" file. Thats the one that displays the info over the little preview in the game. In the case of the top gear track the first line was missing a , (comma) at the end. all ... things should be enclosed in " (quotes) and each line should end in a , (comma) apart from the last line.

    On the top gear track it read....
    "name": "Top Gear 0.8" ..... It should have read..
    "name": "Top Gear 0.8",

    In the case of champions motell, the last line read...
    "run": Drift" ... it should have read..
    "run": "Drift"

    So if you ever get that error and you just added a new track, check its "ui_track.json" file for any missing symbols
    • Beer Beer x 2
    • Like Like x 1