1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DX11 support

Discussion in 'F1 2012 - The Game' started by kimkom, Jan 13, 2013.

  1. Hi all,

    Not sure if this is my first post or not!

    Anyway, I'm wondering if F1 2012 uses dx11? I've seen posts indicating that you need a dx11 hotfix in order to enable it. Is this true?

    If F1 2012 is not natively dx11, how would I enable it?
  2. Fist off which operating system are you running, which video card do you have installed?

    Both F1 2011 & 12 have support for DX10, 10.1 & 11 it does not support DX9 so if your running an older video card that will the issue. Give us the info asked for above and you'll get the solution pretty quick :)
  3. Thanks.

    I'm running Windows 7 Pro 64bit, with an nvidia gtx 580.

    Am I correct in thinking that in my case, F1 2012 automatically runs using dx11?
  4. Yes you are correct. If you have any doubts goto microsofts download centre and get the DX SDK that will ensure you have all the latest files DX requires. Ensure your graphics drivers are upto date and you can be certain that DX11 is being used by the game.

    Have fun racing!
  5. Correct me, if I'm wrong. Most people doesn't need to install DirectX SDK. It's for the developers. The end user need to install DirectX End-User Runtimes (June 2010).
  6. Tom

    Staff Emeritus Staff

    The runtimes should be sufficient for end users, indeed.
  7. Great! Thanks for the info guys.
  8. Quite correct, I put the SDK as its what we download in work :D
    • Like Like x 1
  9. Hawaiian Guy

    Hawaiian Guy
    Banned on request @Simberia

    how do i start this game in dx11? i cant find any option to start in dx11

    Does this game auto start in DX11? My video card is a dx11 card.

    Strangely i have been waiting for this answer for the past 3 years and no one has answered me ;(

    How do i start this game in Dx11 mode?
  10. Sorry for not getting to this sooner. The game when runs will detect your setup and determine which DX version to use. You do not need to do anything :)
  11. Hawaiian Guy

    Hawaiian Guy
    Banned on request @Simberia

    Oh thank you finally after a long year someone answered me :) thank you then i must be in dx11 mode because my card is ati 5970