1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dashboard Android/iOS app

Discussion in 'Richard Burns Rally' started by Joao P. Marques, Apr 3, 2012.

  1. Recently found DashMeterPro for Iracing and Rfactor, which allows live data display on your Iphone or Android phone. Does anyone know of a similar application for Richard Burns? If none exists, maybe a future project for WorkerBee? :)

  2. iDisplay and Sim Monitor can be used to do this. It's a bit fiddly though.
  3. Manuel De Samaniego

    Manuel De Samaniego
    3X Race Department Rally Champion

    I just bought it today and it's great. A bit difficult to get it set to your preferences but it's great. First buy IDisplay and then download Tanatek sim monitor. It will make your head hurt and takes some time to get used to it though.... :confused:
  4. how much information do you get out of RBR with that ? just RPM, Gear and speed ? or do you get engine warning and oil pressure warning etc ?
  5. RBR GAUGES Beta 2 was released yesterday. Test it and post your comments ;).
  6. I couldn't get this to work. Gauge_server.dll gets renamed to Gauge_server.no.
  7. I assume you're testing it via RSCenter. So rename the file back to .dll and start RBR from the original RichardBurnsRally_SSE.exe. Good luck!

    Oh how I wished I had the right gadgets to use this beauty, but can't be helped. :)
  8. Thanks for a great app.:thumbsup:
    It works very well and is really fun to use:laugh:
    But I do not get to everything on the screen for my Samsung Galaxy S III??
    The new analog gauge,(Type 2) I can not see. Speed​​, Boost, wather and time
    when I turn my phone horizontally?????:thumbsdown:
    sorry for my bad English:sick:
  9. Can you make a photo of how it looks on your device? I am testing on an HTC Wildfire S (Android 2.3.3) and a 9.7" tablet (4.0.1). On my test systems all seems to work great.
    You can contact me by e-mail - it is provided in the readme.
  10. Thanks. Tried that and this time it shows up in Plugins and the file is not renamed. However, still not working. Log file says "Creating socket....ERROR". I'm using a Google Nexus 7 tablet to connect. It can ping the server. The website says the server uses port 8673. However, telneting using another computer to port 8673 fails.

    Anyone has any ideas?
  11. Firewall?

    Oh, and that Socket Error can be displayed couple of times. At the end there has to be an OK message. It is due to that I have to let RBR initialize networking ;).

    This is a typical log from my system

    Creating socket .... ERROR
    Creating socket .... ERROR
    Creating socket .... OK
    Binding ....OK
    Listening ....OK
    Server listening
  12. Just a friendly hint.

    For this application you should use a private port in the range 49152 through 65535.

    A port like 8673 usually is reserved by the IANA, which manages the registration of those ports.
  13. Tried it with firewall and antivirus off. It has many Creating Sockets....ERROR and I shut down RBR, it Server shutdown (or something similar, pc is off at the moment). No binding or listening.
  14. Tried to run RBR as administrator? It seems that the OS does not allow the plugin to create a socket for some reason.
  15. Well, it is obvious from the IANA database that this port is not being used, but using it for your own purposes is a different story.

    Quote from IANA ports document:
    That is what I was talking about.
    You may use this port, but if someone registers it, you and your users may get into trouble, 'cause some weird effects may occur.
  16. Yep, same thing running as administrator.
  17. WorkerBee, if this port will be assigned I will update the solution. You are talking about a purely virtual issue. I am fully aware of all possible issues of using a port number from the User Port set.

    itrdc5, can you mail me please? My mail is in the readme file. It will be a lot easier to do the investigation via e-mail because I have to prepare a debug version for you. Hopefully I'll be able to help ;).