1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Checkpoint / Sector Locations

Discussion in 'Bob's Track Builder' started by wagnerov, Feb 23, 2011.

  1. Hello,

    Does anyone know where in the AIW file (or elsewhere) that the sector locations are set? No matter what I do with BTB or editing the AIW to set them manually or by percentage, they always seem to be a 33.3% distance on the track. In BTB, it looks like you can set the "window size" for the sector too...and I am thinking wherever that is set is what is causing my problem.

    Here's what is in the AIW file currently:


    Something is overriding this. Guitarman's AIWCAM editor is also showing the sectors where I want them. Are they attached to a waypoint?

    Thanks for all the help!
  2. Kyle Puttifer

    Kyle Puttifer
    @ Simberia @Simberia

    The timing gates are actually GMT files and are referenced in the SCN. My best guess is that the GMT contains data about where the model is relative to the point (0,0,0). I don't know, but you can't do timing gates in the ISI editor AFAIK, so I don't think they'll be in the AIW.
    If you look in the SCN file near the bottom you'll see references for xfinish, xsector1 and xsector2.
    The only reason they are attached to the centreline in BTB is to help you position them properly.
  3. So if you manually set Sector 1 to be, for example, 10% distance in to the track, when you get into Rfactor its still 33%?
  4. I'll give that a shot! Thank you. Yeah, I was poking around the ISI AIW editor, and didn't see any way to set them there. That should have been my first clue. It is interesting that the distances change in the AIW as noted in my copy/paste above, but they definitely don't do much from what I can tell.

    Off to muck with the SCN file now. thanks again!

    Edit: fixed by overriding old GMT xsector files. thank you!
  5. OMG, i was about to ask for help for correcting the sectors shown in the map and i realized that after i make the correct xsectors (EVO so they are in the .trk file...), i need to reposition them manually in the AIW too. So thank you for helping with out even knowing it.