1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't load my track

Discussion in 'Bob's Track Builder' started by kapten_zoom, Jul 10, 2009.

  1. I've been working on my track "Trollåsen" for a couple of weeks and is soon almost done. But yesterday I did some changes on the track and exported it to rFactor and got the errors:

    Error loading texture troll?sen for material grass 0_0

    followed by:

    Error loading global material grass 0_0

    I've tried changing the grass on the whole track, that only gave me problem with the material that I uploaded instead. It's like it doesn't want to load the ground texture. Would be very happy if some kind soul could help me :glasses-nerdy:

    Regards Fredrik Lundvall
  2. Problem solved so no need for answers :tongue:
  3. Same problem here

    Hi Kapten, I was wondering how you fixed the problem, I had the same errors on my track.
    Thanks for any help
  4. power of 2 , must be applied to rfactor .

    32,64,128,256,512,1024,2048,4096 to the texture (width/hieght not need to be the same,has long has it one of the above numbers)
  5. thx for the reply Banger, but I dont understand your answer. Is it for when making textures, pixel dimensions?

    Anyway Im using BTB textures so I dont understand why they are failing, everything was working fine on early test runs in rFactor but now I get the error when trying to load track in rFactor.

    the error is...
    gMotor 2 Error
    Error loading global material grass2_0

    I made a simple test track and used the same grass texture and it loaded in rFactor fine.

    This is my first track so Im sure its something I messed up.

  6. are you using a screen jpg to blend to the btb terrain, if yes then re size your image to to any of the numbers in the above post.use the screen.jpg file in rfactor and re size it.not the one in btb folder. for obvious reasons.:). and next time resize it before importing it to btb...lesson learned ..hehe
    if it just a standard texture jpg, make sure it dimensions are has above numbers list.
    gmotor2 global errors are usally image files related,.it needs to be at a certain dimension.not great than >4096

    so basically check each texture to see if the have the right dimensions in rfactor folder.
    from the list above.especially the background picture if you have one inserted.
  7. ahhhhh, thx banger!

    makes sense now.

    *buys Banger a beer*