• So long as all your wheels are pointing in roughly the same direction, you should be fine.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Can't get a desktop shortcut with attributes to work

Discussion in 'Stock Car Extreme' started by Martin Vindis, Apr 12, 2015.

  1. Martin Vindis

    Martin Vindis
    Premium

    Messages:
    459
    Ratings:
    +222
    I'm trying to set up a shortcut on my desk so I can join a server quickly.

    I wrote this in the target text field "D:\Spel\GSC 2013\GSC.exe" +connect <IP:pORT> +password "<PASSWORD>"

    The shortcut makes the game connect to the server but I still have to enter the password manually. I tried running the command in a command shell and it works fine.

    Any ideas what's wrong with my shortcut?
     
  2. JoelGL

    JoelGL

    Messages:
    1,120
    Ratings:
    +82
    I'm 'guessing' the double quotes on the password?
     
  3. Martin Vindis

    Martin Vindis
    Premium

    Messages:
    459
    Ratings:
    +222
    I tried without quotes and single quotes, still same thing, the documentation on rFactor says double quotes and it works with double quotes when running from a command shell so it's not it.

    It seems like the password attribute doesn't get passed along. When I deliberately enter wrong password in the command shell I get a message saying "Bad password" but when running the shortcuts I only get the "Enter password" message no matter if the password is wrong or right.
     
  4. Martin Vindis

    Martin Vindis
    Premium

    Messages:
    459
    Ratings:
    +222
    Ok, so I enabled the trace attribute and here are the results


    When running from the shortcut the log file looks like this

    TRACE LEVEL = 1
    NetComm.cpp 11276: NetComm checking command line: "trace=1 +connect 127.0.0.1:34597 +password SecretPassword"
    NetComm.cpp 11372: NetComm activated autojoin mode


    And when ran from the command shell it looks like this

    TRACE LEVEL = 1
    NetComm.cpp 11276: NetComm checking command line: "trace=1 +connect 127.0.0.1:34597 +password "SecretPassword""
    NetComm.cpp 11297: Setting Game Password to: "SecretPassword"
    NetComm.cpp 11372: NetComm activated autojoin mode


    From what I can see the double quotes around the password doesn't gets removed and thus it wont work. What's going on here? =/
     
  5. Martin Vindis

    Martin Vindis
    Premium

    Messages:
    459
    Ratings:
    +222
    Sorry for being spammy but got another update.

    If I put a white space in the password it works. Seems like it's a windows thing that removes the double quotes if there is no white space between them.