• "Bite off more than you can chew and then chew like hell." - Peter Brock
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Thrustmaster 24 Hours of Le Mans (LIVE)
Click the cross to dismiss this video
Dear fan, please make sure to like the video and subscribe to our channel to be eligible to win this round's prize provided by our sponsor.

Can't download nothing...(says slow down)

Discussion in 'Site Feedback & Support' started by Jugador, Aug 2, 2011.

  1. Jugador

    Jugador

    Messages:
    12
    Ratings:
    +0
    Hey guys...sorry if this is an old issue, but haven't been here in awhile. Whenever I try to download any file, I get this message (see pic). It always says "Slow Down", but I haven't even downloaded anything, yet. Thanks :cool:

    [​IMG]
     
  2. Senad Subasic

    Senad Subasic

    Messages:
    8,711
    Ratings:
    +1,901
    Hiya :welcome:

    Not sure if it's a known issue. The generic solution would be to try logging out, clearing cookies, and logging back in.
     
  3. Jugador

    Jugador

    Messages:
    12
    Ratings:
    +0
    Yeah, logging out did it. :woot:

    Thanks for the tip...the sites looking good. Now excuse me while I look around...:cool:
     
  4. Jugador

    Jugador

    Messages:
    12
    Ratings:
    +0
    Well, dang it...it's doing it again. I logged out 2 days ago, logged in this morning and tried to download a small 500kb file, and I got the "slow down" flag again. Anybody got any suggestions on what the problem is? Thanks
     
  5. Bram

    Bram
    #27 | Roaring Pipes Maniacs Staff Premium

    Messages:
    41,886
    Ratings:
    +16,120
    Make sure you are not using a download manager (that's very 1990s) as simultaneous connections are not allowed. Thats the only thing causing it apart from double clicking the download button.
     
  6. Jugador

    Jugador

    Messages:
    12
    Ratings:
    +0
    Okay, thanks for the tip. I use Mozilla Firefox browser, but I don't know if the downloader is the problem or not. This is the
    only site that I have this problem, tho. Thanks
     
  7. Jim Cole

    Jim Cole
    Premium

    Messages:
    1,703
    Ratings:
    +122
    set firefox look for new page every visit and see if that resolves the issue. Also you can delete your history on exit of firefox through the settings. Alternately you could set firefox to not remember history at all, but if your like most folks, that is how they find the pages they have visited in the past :)
     
  8. Jugador

    Jugador

    Messages:
    12
    Ratings:
    +0
    Took me awhile to figure out what you were talking about, but changed it from "3" to "1", and still no joy. Thanks for the tip, tho.

    If anybody else wants to try it and don't know how, here's a link...Firefox Caching