1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Blank Class icons after installation

Discussion in 'RACE 07 - Official WTCC Game' started by kingsti, Dec 27, 2009.

  1. Hi all. I wonder if anyone has seen this before.

    I just bought Race on and installed it over an existing GTR Evo which had several mods already. Now when I fire up Race On, Select Track and go to the Class page, half of the icons are missing so I can't tell which box relates to which cars. Clicking blindly on the box brings up the mod though.

    Do you think I have to reinstall all my mods or is there a way to fix it.:confused:

    Thanks in advance.
  2. Bram

    Roaring Pipes Maniacs | #27 Staff Premium Member

    Probably your mods causing that problem. Would always install/upgrade on a clean version. Maybe try to move your race 07 folder temporary elsewhere, force an update by removing the two .blob files in your steam folder (save login and password first) and see if that helps?
  3. Warren Dawes

    Warren Dawes
    Premium Member

    This problem was a result of Simbin changing part of the file structure with Race On, but is easily fixed.

    1. You could just launch the game using the older GTRE Icon if you still have it

    2. But the better way is to move some files.
    Open up your main Race 07 Folder, go to\UIData\Menu\Textures_Mamba and copy all of the files in that folder, and then paste them into UIData\Menu\Textures.

    Then no matter which Icon you use to launch the game, all of your addon icons will be displayed.
  4. >>Fantastic. This worked for me. I wasn't looking forward to reinstalling everything again. Thanks very much Warren! And thanks Bram for your suggestions. :wink:
  5. Yes thank you very much!
    I have the same problems,
    luckily it's only buugging the presentation and
    not the gameplay.

    Sure it is caused by mods?
    I never downloaded
    or installed one...
  6. I think that Warren's comment about the change in file structure is the key.
    I'm not sure now which ones are standard and which ones are mods in my setup, but when I followed his suggestion there were still some icons which were not restored. To fix these, I had to copy from Addons\GTR Evolution\UiData\Menu\Textures_Mamba into UIData\Menu\TexturesUIData\Menu\Textures as well.
  7. Textures_Mamba = shows up in GTR Evo only.

    Textures_Frog = shows up in STCC only.

    Textures_Toad = shows up in Race On only.

    Textures = shows up in all expansions :)