1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Beta Innovations Nitro SLG & Plasma Lite V2.0

Discussion in 'Sim Racing Hardware' started by Mark Reynolds, Dec 26, 2011.

  1. Mark Reynolds

    Mark Reynolds
    Physics & AI Programmer

    I have a Nitro SLG running my gauges and LCD gear shift display, works just fine, however when I plug in my Plasma Lite V2.0 my 20x4 LCD screen works just fine but the gauges and gear shift all stop working, I am guessing there is a USB ID conflict between the Nitro and Plasma, both work perfectly stand alone.

    Would be nice to have my 20x4 working with the gauges and shift display, have tried all the combination of options in the RSIM software but at a loss now ?

    Anyone got any experience of this, I seem to recall reading a long while ago you could not have both the 20x4 and gear display at the same time, but cant remember for sure ?
     
  2. What version of firmware for the Plasma do you have and what version of RSIM? I have run a 20x4 LCD and SD9 off a Plasma Lite no probs before.
     
  3. Mark Reynolds

    Mark Reynolds
    Physics & AI Programmer

    Will check it out when I get back home next week and let u know, thanks.

    Definately early versions of both software and firmware. Would have no idea how to flash either with updates or indeed where to get those updates either.
     
  4. Mark Reynolds

    Mark Reynolds
    Physics & AI Programmer

    Ok, I have

    RSIM 2.5.1.0

    Flashed both the Plasma and Nitro to latest firmware using the device manager.

    Have re-assigned the hardware ID so that one is 000 and the other 001, tried both ways around.

    Both still work flawlessly independent from each other but not together, the nitro always stops outputting to the SL9 and gauges both in RSIM and ingame. As soon as I unplug the Plasma normal service resumes on the Nitro.
     
  5. Mark Reynolds

    Mark Reynolds
    Physics & AI Programmer

    I have the SL9 plugged into my nitro and not the Plasma btw.....only thing plugged into the Plasma atm is a single Momentary switch i'm testing, and the 20x4 LCD
     
  6. Mark Reynolds

    Mark Reynolds
    Physics & AI Programmer

    just discovered that if I alt Tab out to the RSIM software and then click on plasma, then on Nitro everything seems to work, a workaround but not ideal eh.
     
  7. Mark Reynolds

    Mark Reynolds
    Physics & AI Programmer

    Ok, another update.

    Depending which has the selection in RSIM depends which will output, if the Nitro is selected everything on the Nitro outputs, ie gauges and the SD9, nothing goes into the 20x4 at this point, if I tab out and select the Plasma then the output works on the 20x4 but nothing from the Nitro.

    Now whilst it would be nice to have an output to the 20x4 at the same time as the gauges and SD9 its not essential, my main use for the Plasma will be switches and a couple of axis, so at least I can have that working fully even if the 20x4 doesnt wanna play ball with the Nitro at the same time.

    Wondering if I should sell the Plasma and 20x4 LCD and just buy another cheap switch/axis controller instead tho ?