• "Mwoah" - Kimi Räikkönen
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Automatic steering range not working with my G27

Discussion in 'Automobilista' started by Liptak Balazs, Dec 29, 2016.

  1. Liptak Balazs

    Liptak Balazs

    Messages:
    5
    Ratings:
    +1
    Hi!
    First of all, sorry for my English.
    In my Logitech Profiler the "Allow games to adjust settings" enabled, and i have 900 degrees rotation.
    In the game, the custom steering wheel range is set to off. ( I also tried to set it to enabled, and set the rotation to 900 degrees, and then set it off, but it's not working).
    What is the problem? It's really hard, to go with 900 degrees even with a formula car.
    This is the only game where i have this problem, in Assetto Corsa and rFactor 2 this option works well for me.
    (I also tried to run the game as administrator).
    Here is a video about my problem:
     
  2. renan_ma

    renan_ma

    Messages:
    41
    Ratings:
    +37
    some times this happens
    you should erase your profile folder in the game folder (i think is in my documents)
    then create a new one in game, reconfigure the wheel again, see if this work
    *remember to save your settings folder first unless you want lose all the set ups you have
     
  3. Liptak Balazs

    Liptak Balazs

    Messages:
    5
    Ratings:
    +1
    I deleted my profile, but nothing changed, still not working :(
     
  4. renan_ma

    renan_ma

    Messages:
    41
    Ratings:
    +37
    well, one last thing you can try is delete the game, and the my doc folder, then install it again.
    if that doesn't work try contact Reiza through email.
    or post it here: http://forum.reizastudios.com/
     
  5. Liptak Balazs

    Liptak Balazs

    Messages:
    5
    Ratings:
    +1
    I posted there before here, but i didn't get any answers yet. Now i reinstalled the game, but i still have the same problem. I will write an e-mail, and hope, that the developers are know, why it's not working for me :(
     
  6. Mat Kane

    Mat Kane

    Messages:
    35
    Ratings:
    +11
    Liptak, is this a recent problem, or did you have it working before and now it's broken?

    I remember having something like this happen to me once in a while with my G27. For me it was an odd interaction between the Logitech profiler and the game settings.
     
  7. Liptak Balazs

    Liptak Balazs

    Messages:
    5
    Ratings:
    +1
    It was never working, it is like that, since i installed the game.
    What was the problem, with your profiler?
     
  8. renan_ma

    renan_ma

    Messages:
    41
    Ratings:
    +37
    yes you can try to delete the profiler and traces of it in the "human interface devices" in yours usb port.
    then download the profiler again, and maybe you are using an old version of it no?
     
  9. Mat Kane

    Mat Kane

    Messages:
    35
    Ratings:
    +11
    I believe what I had to do was to close AMS and delete the controller profile I'd created, then open up Logitech Profiler and confirm that the wheel was set to 900 degrees. Start up AMS, go to the controller menu and load the default G27 from the preset profiles available. I'd save this profile with a new name, and make the changes to the button assignments after that.

    I don't understand completely what was happening, but I think it was something to do with the rotation values not resetting themselves, or the profile I'd saved becoming corrupted.

    Good luck!

    Edit: As suggested above, making sure the Profiler software is up to date won't hurt.
     
  10. LetsTestDrive

    LetsTestDrive

    Messages:
    8
    Ratings:
    +1
    This is not a 100% fix, but will get you pretty close to the correct rotation and playing/enjoying the game.

    Hold down buttons 2+1 then press a corresponding S,T,X or 0

    [​IMG]

    [1+2] + O = ~670°
    [1+2] + S = ~450°
    [1+2] + X = 900° Resets to default
    [1+2] + T = ~240°
     
  11. fapador

    fapador

    Messages:
    1
    Ratings:
    +0
    the solution is to not run the game as administrator it interferes with ams
     
    • Love Love x 1