1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PC Assetto Corsa Logitech G29 Settings

Discussion in 'Assetto Corsa' started by meggeskind, Feb 5, 2016.

  1. Hi guys
    I got the g29 and ac yesterday and i havent been able to find good ffb settings yet. If any of you have some id appreciate it if you could share them. Thx!
  2. I left the default G29 settings once applied from the left window and then knocked down the gain to about 60% which gives good feel.

    One thing I am struggling with is getting the clutch to be accepted in the settings, it just won't acknowledge that there's a clutch and I'm using the H shifter. When I press the clutch pedal it shows it moving under number 7 but when I try to apply it to the actual control it will not recognise it. Also when I depress the pedal it looks like it's digital, that bar just jumps from half way to zero, there's no progressive movement in it and I'm assuming the game is thinking my clutch pedal is a button so it won't allow it.
  3. alright thanks for the answer. my clutch is working fine but i dont have the h shifter. dont know if that makes a difference
  4. i have just bought the G920 Wheel(same as g29 but without led & extra (ps3) buttons ,still looking for the feel i had on the dfgt and g27,been trying for a day now , the wheel isnt very well supported in most games ,it doesnt use logitech profiler ,only the newer LGS which has less functionality than the old profiler
  5. C:\Program Files (x86)\Steam\steamapps\common\assettocorsa\system\cfg

    Open assetto_corsa.ini and change damper gain to 0. After you can also try ff skip steps 0, because at 1 the frequency is half. Although more frequency can give problems in certain PCs, but if you're fine, keep the setting to 0.
    Also in case there's game update or you verify cache integrity files, that file can be restored to default values, so you'll need to check the file in those situations.
  6. This is mainly regarding Assetto on PC with a g920 ( but it seems its not just AC also PCars)
    firstly thanks for the reply ,
    have already tried the O.p's setting ,and many of my own
    done the:
    "Open assetto_corsa.ini and change damper gain to 0.+ After you can also try ff skip steps 0, because at 1 the frequency is half.
    also tried deleting the controls.ini file in my documents and going thru the wizard,rebuild game thru steam,fresh install.
    but the problem is driver related ,been researching all day today,i am not alone check here same issues
    http://forum.projectcarsgame.com/showthread.php?40502-Logitech-G920-FFB-on-P-C-***PLEASE-HELP*** ,whilst the wheel works better on project cars it still has poor FFB,no centre spring,the profiler whilst looking pretty ,is poor and has less functionality than the old profiler

    first read this : https://forums.logitech.com/t5/Logitech-G-Controllers/G920-on-PC-is-a-disaster/td-p/1436049

    also read this : https://steamcommunity.com/app/244210/discussions/0/523898291513578311/
    at the bottom quote:
    Snatched this from the support forum thread.

    AC Support
    Official Support
    "We are in touch with Logitech about this issue and we are working on it."

    the software from logitech (LGS v8.81.15)is installed & drivers and wheel has had
    The Update called "g920Update_v43.exe"
    available here : http://www.logitech.com/pub/techsupport/gaming/G920Update_v43.exe
    they working in Raceroom and LFS ,next racing game,race 07,gta v, it seems the FFB on this wheel is very poorly implemented on all games ,ATM My DFGT walks all over it
    other info : fresh install of genuine. win 10 64 pro with all updates ,no malware,viruses ,fresh install
    running at 5860x1040 mainly racing on Assetto so this one is most important

    My Assetto.ini file:

    FF_SKIP_STEPS=0 ; Physics engine steps to skip in order to accomodate wheels with lower FF input buffer

    DAMPER_GAIN=0.0 ; Set to 0 for Logitech g920





    USE_TIMER_PROCESS=-1 ; -1=Automatic, no timer process for CPU with more than 2 cores, timer process for dual cores. 0=Always off. 1=Always on.
    SET_THREAD_AFFINITY_MASK=0 ; 0=Windows scheduler will decide where to run the threads. 1=Main thread assigned to Core0, physics thread assigned to Core1










    SPEED_KMH=3 ; Under this speed the reduction will start
    MIN_VALUE=0.01 ; The FF multiplier for 0kmh.

    THREADS=-1 ; -1 = automatic , 0 = disabled , 1...N number of threads dedicated to physics

    FORCE_TGT=0 ; 0 = Use High Resolution Timer until a drift in time happens, 1 = use 1ms resolution timer


    also posted here :: http://www.assettocorsa.net/forum/index.php?threads/g920-pulls-to-full-right-lock.30992/

    EDIT: JUST FOUND THIS...,better but not perfect in the assetto.ini file change the line
    centre spring is there,and more realistic but weak FFB
    Last edited: Apr 1, 2016
    • Like Like x 1