1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Appcrash error, game won't start!

Discussion in 'F1 2010 - The Game' started by glight, Jul 25, 2011.

  1. Guys, I know this has already been discussed but does anyone know of a fix for this? I can't start my game anymore not even the splash screen comes up and sometimes I'm not even notified that it crashed. I don't have the exact details that it spits out but the error is an APPCRASH and it complains about ntdll.dll being the cause.

    Here is what I've tried

    1. Reinstall the game

    2. Roll back graphics drivers to catalyst 11.5 (since I knew for sure those worked)

    3. Make sure hardware_settings_config.xml specifies WorkerMap4core.xml

    4. Make sure msconfig.exe specifies 4 cores at startup

    5. Uninstall GFWL and reinstall (it then complains about a missing component error)

    None of this has worked unfortunately. I have garnered 2 more things to try though:

    1. Start the game from windows' safe mode

    2. uninstall gfx drivers, use driver sweeper, reinstall gfx drivers

    3. download a new copy of ntdll.dll

    4. uninstall GFWL and Microsoft C++ 2005 redistributable, reinstall GFWL

    5. do a "clean boot" (only scan registry and systray in msconfig.exe startup tab)

    6. run f1_2010.exe as admin

    7. make the replay file read-only ( found in C:\ProgramData\Codemasters\FormulaOne\DataCache)

    8. Reinstall DirectX

    9.Run windows update

    10: Start from scratch: Format C:\, reinstall windows, steam, F1 2010 etc.

    Could it be my reinstalled GFWL that is bothering it? (the problem still existed with my old installation of GFWL) does anyone know how to fix that issue as well?

    Please help!

    edit: added some more possible solutions from codemasters forums
  2. Andrew Bortz

    Andrew Bortz

    Have you tried verifying game cache files through steam?
  3. My game is freshly installed from steam so I don't think that's the issue, will give that a try tonight anyway, thanks (at work right now)

    edit: Steam says everything is all good, so no luck there
  4. I am trying out a fresh install in virtualbox right now, hopefully that will work. Not looking forward to reformatting, thank god I keep all my data on D:\ (already backed up my heavily modded Fallout NV too).

    Still would be nice to know why my game all of a sudden stopped working. I made sure to revert the gfx driver update and uninstall the motioninjoy ps3 controller drivers that I recently installed since those were the only things that I've installed lately.
  5. Andrew Bortz

    Andrew Bortz

    Was gonna suggest doing astystem restore back to when it did work?
  6. Completely forgot about that! I haven't reformatted yet so I'll try.
  7. Ok, well System restore wasn't any help; it didn't go back far enough (only to Sunday and I would have needed at least Friday). I figured the root cause was GFWL so I continued searching how to fix that and a suggestion I found was to try logging into Live Messenger (after checking the BITS and Windows Live ID Sign-in assistant services were indeed running). Surprise, surprise I couldn't log in!

    Anyway my game works now. I reformatted and installed Steam, then F1 2010, then signed into GFWL, let it update itself (twice). This time I made a system image after I'd ran all the windows updates and installed everything except AMD drivers, Steam, F1 2010 and GFWL so I have a way to get back to a clean slate if this ever happens again.

    I don't think I will ever finish a season in this game:damnit: