• "Slow and steady finishes the race. Fast and steady wins the race." - Sean Rogers.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Alfa Romeo 4c upshifting - sound and loss of RPM

Discussion in 'Assetto Corsa' started by Sk3ptik0n, Mar 28, 2015.

  1. Sk3ptik0n

    Sk3ptik0n

    Messages:
    1,031
    Ratings:
    +222
    I have been trying to drive the 4c lately but I get very irritated by its behavior when I upshift. It feels like I am going from 1st to 3rd or 4th , then when I am on 2nd, feels like I am upshifting another g=ear or two instead.

    The sound of the engine and the RPM get a real dip as if the car was using a turbocharger from the very down of automotive technology. I will drive the car up to ted lin, shift and then it will drop several hundred RPM with a corresponding lag in the sound of the car.

    Is anyone experiencing anything like this or should I try reinstalling the car.

    From youtube I can tell this car doesn't do that IRL.

    If the above is not clear, I'll try to grab a video of it for you guys, but if this not only happening to me it should be annoying to everyone else too.
     
  2. Bram

    Bram
    Administrator Staff Premium

    Messages:
    41,950
    Ratings:
    +16,171
    Have you tried to manually blip the throttle on up and downshifts to keep the revs up?
     
  3. William Levesque

    William Levesque

    Messages:
    4,894
    Ratings:
    +1,276
    Upshift when the rev counter gets yellow. Red is too far.
     
  4. Chris

    Chris
    Ted Kravitz Appreciation Society Staff Premium

    Messages:
    9,329
    Ratings:
    +5,740
    Would you be able to upload some video footage of it?