• "Slow and steady finishes the race. Fast and steady wins the race." - Sean Rogers.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AC: Stuttering reduction

Discussion in 'Assetto Corsa' started by Rick Malm, Jun 8, 2014.

  1. Rick Malm

    Rick Malm

    Messages:
    289
    Ratings:
    +28
    What can a user do to reduce or eliminate stuttering even in practice runs where their are no other cars on the track?

    With Lotus F1 on Monza track I sometimes get as many as 6 stutters per lap, sometimes its 0 which is great.


    What is the key cause of stuttering when running AC local vs MP which involves network response time as well as AC MP implementation?

    Background:

    My system: CPU: Intel i7-4770K Haswell 3.5GHz (some small amount overclocking was installed from Main Performance)
    Video: NVIDIA | EVGA GeForce GTX 780Ti to 3 ASUS VE278Q 27” monitors 85hz refresh


    I use a SSD memory for the AC install (The SSD is my C: drive)
    My cpu usage is about 26% when AC is running. Processor Affinity shows all checked (0 to 8), Priority=Normal,
    window resource monitor shows the cpus are getting used and none are any where near 100%, more like 40-50% and there are graphics showing PARKED cpus.

    I turned off the car interior controllable items: no wheel, no driver arms.
    I set Frame Limit to match my monitor max at 85.
    FRAPS shows FPS will dip to 67 in some corners.
    I tried reducing smoke generation and mirror resolution, I turned blur off completely.
    I have not turn off HDR yet.
    I have not tried to us msconfig and kill all background processes. I typically have firefox running in the background
    which is the larger memory user (then Spyhunter4, explorer, LCore, office.bin, Steam....)
    I have not tried to ALT-TAB out of AC when I see stuttering to see what is running with the resource monitor.
    After I ran the resource monitor and looked at the CPU tab and saw a number of PARKED cpus I downloaded and ran a disable parking utility (edits the registry). This seems to have helped. Any problem with doing this?

    http://coderbag.com/Programming-C/CPU-core-parking-manager

    http://www.coderbag.com/Programming-C/Disable-CPU-Core-Parking-Utility

    AC settings: Fullscreen Rendering ON | Triple Screen ON (6065x1080) | Vsync - OFF | Frame Limit - 85 | Aniso x 8 | AA x 4 | FXAA x 3 | Shadows -Low | World Detail - Maximum | HDR Color Sat On @ 92%| Smoke Generation – Low||Smoke in Mirrors OFF| Motion Blur - OFF | Mirror Resolution High| CubeMaps at Low | Faces per Frame - 4
     
    Last edited: Jun 8, 2014
  2. Michael Hornbuckle

    Michael Hornbuckle

    Messages:
    2,387
    Ratings:
    +2,169
    turn vsync on.

    Works like a charm for me...curious though, why you use both AA and FXAA?
     
    • Agree Agree x 2
  3. Blkout

    Blkout

    Messages:
    2,684
    Ratings:
    +568
    Vsync on will cause problems if you can't maintain 60fps and honestly probably in excess of that. My guess is that the issue here is quite simply that the framerate is fluctuating too much. That's a lot of pixels to push with 3 screens. can't hurt to try it though, some get better results with it on and some off.

    Rick,

    1.Have you tried disabling hyperthreading? it almost never helps in games and can cause stuttering.

    2. Try turning off FXAA, there's no need for that with 4xMSAA.

    3. Try turning faces per frame down to 2-3, 4 is asking too much.
     
    • Beer Beer x 1
  4. Michael Hornbuckle

    Michael Hornbuckle

    Messages:
    2,387
    Ratings:
    +2,169
    Even on trips, a 780ti should have no problem maintaining 60fps.

    With vsync off I get 100+ plus frames but there is screen tearing and stuttering....

    Ac is the only game that I have actually used vsync but it works like a charm.
    (unless you suffer from ILS)
     
    • Beer Beer x 1
  5. yusupov

    yusupov

    Messages:
    935
    Ratings:
    +143
    surely he could simply force adaptive vsync to prevent getting slammed to 30 anyway?

    i noticed a stutter for the first time today (havent played much AC at all recently), hope this isnt becoming a problem.
     
  6. Michael Hornbuckle

    Michael Hornbuckle

    Messages:
    2,387
    Ratings:
    +2,169
    Why would he get slammed to 30?
     
  7. Dinca Andrei

    Dinca Andrei
    Premium

    Messages:
    1,615
    Ratings:
    +1,168
    Triple screen setup here,only its the smaller version (3980x1024 @60Hz) and i have no lower than 42-45 fps with full grid in multiplayer...agree that i still have some tearing (VSync ON) but no stuttering
     
  8. Rick Malm

    Rick Malm

    Messages:
    289
    Ratings:
    +28
    Blkout and Horbuckle,
    Thanks for the help on items that I had no idea what to set them to.
    FXAA now off
    Faces Per Frame at 1 and its real smooth looking.
    FRAPS shows average at 84.235 (max 86 min 84)
    and given my monitors at 85hz this is perfect. I have frame rate limited to 85
    with 9 cars on the grid, all Lotus 125 S1.
     
    • Like Like x 1
  9. Requiem84

    Requiem84

    Messages:
    361
    Ratings:
    +229
    Or: cap frames to 60 instead of using vsynch.
     
    • Beer Beer x 1
  10. Michael Hornbuckle

    Michael Hornbuckle

    Messages:
    2,387
    Ratings:
    +2,169
    I tried that Requiem, and still got bad screen tearing.
     
  11. yusupov

    yusupov

    Messages:
    935
    Ratings:
    +143
    @MH, basic vsync will alternate between refresh rate & half refresh rate, with no inbetween, so if a 60 hz refresh rate youll always be at either 60 or 30 fps (unless you go under 30 of course). adaptive vsync attempts to correct that by allowing frames between 30 & 60, so you wont experience the jarring drop if you get below 60 fps.
     
  12. Michael Hornbuckle

    Michael Hornbuckle

    Messages:
    2,387
    Ratings:
    +2,169
    Ah, okay...I never get anywhere close to falling under 60 so I had no idea.

    Where is this adative vsync, I don't see it anywhere in the control panel.
     
  13. yusupov

    yusupov

    Messages:
    935
    Ratings:
    +143
    very last setting -- vertical sync.

    if you ever use it, be mindful of option to use adaptive half refresh rate, which will lock you at 30 fps, again assuming a 60 hz monitor.
     
  14. Rick Malm

    Rick Malm

    Messages:
    289
    Ratings:
    +28
    Look here at the attachment, I just tried it. My FPS drops to 60 from 85 with it set to adaptive. I also see a little more tearing delta (error between horizontal line scans, looking pole width at Monza back side light polls vs at 85 vsync=off the tear is shorter. It seems like there are more tears with vsync=off. For some reason the adaptive=vsync total image feels smoother. Maybe this is due to the fewer number of tear lines even given that they are larger is tear size. Of course a screen shot show 0. But a movie of the screen will give you the idea. Fewer tears but I see they are about the same length when they get captured. About 1.5 pole widths for no sync and > 2 pole widths for adaptive. Notice fewer poles are torn in the adaptive sync video. If anyone wants the video I could dropbox them to see how many poles get torn in a few seconds of video. Single step to see frame of issues.
    https://dl.dropboxusercontent.com/u/21174582/adaptiveVsyncFPS60.MOV
    https://dl.dropboxusercontent.com/u/21174582/vsynOffFPS85.MOV
    adaptive vs sync off.jpg adaptive Vsync.jpg . (about 1M each, RD does not support upload of .Mov filetype)
     
    Last edited: Jun 9, 2014
    • Like Like x 1
    • Beer Beer x 1
  15. Doug Taylor

    Doug Taylor

    Messages:
    551
    Ratings:
    +171
    I too get an occasional blink, but frames stay the same. This started happening some updates back! Who knows....not i. lol
     
  16. Rick Malm

    Rick Malm

    Messages:
    289
    Ratings:
    +28
    I just go 2 stutters on last lap. I guess I dont have it completely fixed. Maybe the AC code will improve this over time.
     
  17. Blkout

    Blkout

    Messages:
    2,684
    Ratings:
    +568
    Rick, again, using triple monitors is a LOT of pixels to push for a single 780ti. You're likely just going to have to start backing down the detail some to reduce any stutters. Did you try setting cube map resolution to low and faces to 1?
     
  18. Rick Malm

    Rick Malm

    Messages:
    289
    Ratings:
    +28
    Yes I did set faces to 1 per your suggestion.
    Lowered cuemaps as well to Low.


    I did a unpark all 7 cpus.

    Firefox was running 300M in the background that I could kill. I dont think it was doing anything.

    Getting a pretty constant 60fps with 9 cars on the track, monza, lotus exos 125 s1.

    What about HDR, would it change stutter and tearing? I have not tried switching it on and off.

    Would be hard to give up World Detail but I could get used to it
    and Mirror resolution High is clearly not that high anyway.

    Actually I have more problems with AI guys running into me even when I give them plenty of room. I need to calibrate locations vs mirror images.

    Vsync - adaptive | Frame Limit - 85 | Aniso x s | AA x 4 | FXAA = 0 | Shadows Low | World Detail Maximum | HDR Color Sat On @ 92%| Smoke Generation Low |Smoke in Mirrors OFF | Motion Blur OFF | Mirror Resolution High | Cubemaps Resolution Low | Faces per Frame 1
     
  19. Blkout

    Blkout

    Messages:
    2,684
    Ratings:
    +568
    HDR does cause a framerate reduction so you can try turning it off, it just isn't quite as pretty.

    World Detail and Mirror Resolution isn't that taxing.
     
    • Beer Beer x 1
  20. Blkout

    Blkout

    Messages:
    2,684
    Ratings:
    +568
    What are you using for transparency antialiasing in the Nvidia control panel? I would suggest multisampling if you're using supersampling.