1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

PC AC on Rift is sometimes dark, sometimes bright. Any ideas?

Discussion in 'Assetto Corsa' started by Skooter, Aug 4, 2015.

  1. Hello everyone,
    I enjoy driving in Assetto Corsa on the Oculus Rift. I have a problem that often happens when I'm launching the game. Sometimes, it's much dimmer than it should be. Other times, it's perfectly bright. I cannot figure out what causes it. I can launch the same car, same track, two times in a row with the Rift sitting still on my desk... and once it will be dark, and another time it will be bright.

    I often have to launch then kill the game several times in a row before it finally launches with the proper brightness.

    I've searched the net and other forums for this issue and can't find anything about it. The problem persists with different version of the Oculus and Nvidia drivers, so I don't think that's the issue. I do not experience this with any software aside from AC.

    Has anyone else experienced this and found a solution?

    The side-by-side below shows what I'm talking about. The shot on the left is when it's dark, and on the right is the way it's supposed to be.

    (*note... these are two separate screenshots from separate game launches... it's not that one eye is dark and one is bright)

    Thanks in advance for any help.

    [​IMG]
     
    • Agree Agree x 1
  2. Skooter I have always had exactly the same issue, never found a fix and decided to just live with it, I suspect it is some residual bug in AC's render engine and has never been addressed by Kunos because I do not think they allocate much, if any, time or resources to VR work at this time. Maybe closer to commercial release of the Rift and Vive they may be motivated to go through and clean all the VR code up. Just my impression anyway.
     
  3. I recall seeing a thread on the Official AC forums about that very subject. I believe there was a temporary fix via modified INI file. I'll see if I can find you the link.
     
  4. If you could find the fix, I'd greatly appreciate it. I've searched for this issue and haven't seen anything about it.
     
  5. Stereo

    Stereo
    Premium Member

    I think it's something to do with disabling the auto-exposure in the PP filter entirely, I forget what specific file that is though.
     
  6. C:\Program Files (x86)\Steam\steamapps\common\assettocorsa\system\cfg\ppfilters
    Open which filter you want, and put 0 for auto exposure enable. I don't know if this is the fix, but who has problems with the oculus rift should at least try.
     
  7. pg up and down adjust exposure in game
     
  8. I have post processing turned off, so I doubt it's auto exposure. Just to be sure, I made the edit for Auto exposure and enabled PP but problem still exists.

    Page up/down doesn't do it either.
     
  9. Hm, I could have sworn there was an issue with PP on the Rift - like you needed to have it on or off. Maybe not.
     
  10. Yeah tried all those things and nothing works... it is totally random if it is dark or not, or so it seems.
     
  11. Ugh. Happened 5 times in a row just now. So annoying.
     
  12. Hi mate

    I get this from time to time. Very rarely and much less often than you seem to be seeing it however. I just exit the race back to the menu and reload the race again and it fixes it every time. Like i said though, I see it happen extremely rarely (could probably count the occurrences on one hand) so this is probably not much of a solution for you I'm afraid.

    The suggested solutions posted earlier (regarding the auto-exposure) are for a different issue so won't help you for this particular problem unfortunately.

    Sorry I can't be of more help but I thought I'd at least let you know what I have experienced.

    Cheers and good luck mate.
     
  13. Thanks anyway. It used to only happen about half the time, but lately it seems to be happening more.

    I do the same thing as you, but it's a pain having to launch it 5 times in a row.

    It's impossible to troubleshoot since it's so random.
     
  14. I think this was the fix I was referring to but, I'm now able to use the PP filters and the lighting is better since the last update. I also swapped in a new graphics card so that may have helped.
     
  15. The pp filters are not the problem for this particular issue Racenut. Sometimes the entire view is simply darker than It usually is irrespective of filter used as is shown by the screenshots in Skooters original post, The point being that the same filter will produce either the dark or light view.

    I had it happen again to me today Skooter ... I had just done the race "challenge" event which involves the la Ferrari v McLarens (3 opponents around Nordscheife). That particular event is in the darker weather. I then did a quick race with the settings on clear skies but I had the darker screen again when I spawned in the cockpit. Perhaps going directly from a dark weather race to a clear weather one causes something to go awry? By exiting the race and immediately restarting it, the screen was back to its bright normal self. Perhaps the bright clear skies are not getting loaded correctly the first time after using one of the darker skies settings?

    Something to try I guess, but otherwise I'm out of ideas mate. Good luck.
     
  16. I usually load up the same thing and rarely adjust the weather or time. I'm still looking for any sort of pattern but haven't found any