1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Why is this soooo difficult!?!?!

Discussion in 'GT Legends' started by Cam Wedgwood, May 31, 2008.

  1. I have rediscovered the joy of GTL and would like to get online with it. After reinstalling the game twice, trying the multicode about forty times (U=V=U) I am now (finally) being asked for my login details which (instead of telling me that my cd code is incorrect) is now telling me that my username/password is incorrect. This is promising... I must be getting closer...

    I have gone to the GT legends website to try to get my account details, but the area that I am sure I need to put my details into won't load... Anyone have any suggestions? Very frustrated!
  2. hi when you go to multiplayer try to register in game with a new name it should solve the problem
  3. Have tried that too... Am guessing I need a different email address for it to work.
  4. i have just brought this game and i cant get the multiplayer to work i have accepted from norton,installed the update and it still comes up saying no game any one got any ideas
  5. Do you see the multiplayer lobby ?.
    If you dont then-->register and then log in
  6. i do see the lobby but then i go to register and then log in it comes up saying invaild user name and password
  7. I would try re-register with same user/password/e-mail combo. It should say that there is allready account with same name.
    Then try the Log-in button on that same page.

  8. Abdul Al-Amry

    Abdul Al-Amry
    2011 RD Indy 500 Winner

    Simon I had similar problem just a few days ago. Reason was the username section is CAse SENsiTive :)
  9. The Aha-Erlebnis is all around here. Had also the same issue, always nice to know why stuff doesn't work :)