• "Auto racing began 5 minutes after the second car was built." - Henry Ford
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Visual C++ Runtime Error

Discussion in 'Richard Burns Rally' started by Rhys Gardiner, Jan 10, 2014.

  1. Rhys Gardiner

    Rhys Gardiner

    Messages:
    5,364
    Ratings:
    +767
    I know that there is already a thread out there with this issue, but I thought it best to start a new one as the other one is nearly 3 years old and concerns a different OS. The situation is also slightly different for me.

    I have gotten RBR and RSRBR 2014 up and running on my Windows 8.1 PC. When I start an offline session to test it out, menus and other such things as loading profiles run fine, no issues. I get as far as the loading screen when starting the stage and then the program terminates with a Visual C++ runtime error.

    I have the latest version of Visual C++, I even redownloaded both x86 and x64 versions to be sure. I have not installed it on C:\ drive.

    May I have missed something in the process of installing RBR and RSRBR? Would I have to reinstall both with Admin privileges, maybe? I'm not sure what I can do to fix this.
     
  2. Roy Magnes

    Roy Magnes
    Gentleman Driver Staff Premium

    Messages:
    3,873
    Ratings:
    +1,687
    Last edited: Jan 10, 2014
    • Beer Beer x 1
  3. Ross McGregor

    Ross McGregor
    Premium

    Messages:
    1,815
    Ratings:
    +861
    I had the same issue with RSRBR 2013 with windows 7, and the problem was sorted after I downloaded an older version of Visual C++. Not sure if this helps with windows 8 though.
     
    • Beer Beer x 1
  4. Rhys Gardiner

    Rhys Gardiner

    Messages:
    5,364
    Ratings:
    +767
    @Roy Magnes @Ross McGregor I have tried both of your tips, and it seems that I have it somewhat working, but I'm now encountering behaviour that is even more odd than before.

    First off, it seems that certain stages still give me the runtime error, and other stages don't. For the stages that do work, once I exit the game RSRBR starts it up again without any input from me. Exit to main menu, it starts up again, exit to main menu, it starts up again, and so it continues until I have to close RSRBR or manually end RBR via the task manager.

    Whaaaaaat....
     
  5. Ross McGregor

    Ross McGregor
    Premium

    Messages:
    1,815
    Ratings:
    +861
    Never had that before! Did you install the correct version of visual c++ for your os? You get 32bit and 64 bit versions. Apart from that, maybe it's something to do with the track packs you're using? Try re-installing\downloading.
     
  6. Ross McGregor

    Ross McGregor
    Premium

    Messages:
    1,815
    Ratings:
    +861
    • Beer Beer x 1
  7. Michael Nelson

    Michael Nelson
    #118 RMI Motorsport (RDLMS) Premium

    Messages:
    526
    Ratings:
    +431
    FWIW, I have Visual C++ x64 and x86 versions of the following years: 05,08,10,12 installed on my system.

    Try re-installing RBR and RSRBR from scratch if you haven't. Admin privileges is probably a good idea.

    If that doesn't work, try re-downloading the track packs and re-installing them.
     
  8. Rhys Gardiner

    Rhys Gardiner

    Messages:
    5,364
    Ratings:
    +767
    These are the default stages I'm dealing with - I only tested with France stages.

    I'll try downloading and installing all of the C++ redistributables, and then reinstalling RSRBR with admin privileges.
     
  9. Rhys Gardiner

    Rhys Gardiner

    Messages:
    5,364
    Ratings:
    +767
    Well, nothing's changed. Everything reinstalled, all with admin privileges. I managed to fix the repeating session bug with the fix Ross mentioned above, but my runtime error issue is still there. When I install other versions of the C++ redistributables, should I be getting a prompt to restart the computer every time? Because I'm only getting one with the 2012 x64 version.

    I ran all the stages in the upcoming club rally to see which ones gave me the runtime error and which didn't:

    Puy du Lac - Runtime Error
    Sorica - Runtime Error
    Cote d'Arbroz - Runs Normally
    Bisanne - Runs Normally
    Joux Verte - Runs Normally
    Peyregrosse-Mandagout - Runtime Error

    And there's another issue. The gravel/Monte Carlo/snow mods seem to be unable to load. I'm just getting tarmac textures and car behaviour.

    Right now, I'm at a loss.
     
  10. Michael Nelson

    Michael Nelson
    #118 RMI Motorsport (RDLMS) Premium

    Messages:
    526
    Ratings:
    +431
    The tracks that run normally are all default stages, and the errors are the ones which come with RSRBR.

    Try checking the md5 hashes of all the track pack files you downloaded. All the md5 hashes are written in the track pack post on rallyesim (http://forum.rallyesim.fr/viewtopic.php?f=497&t=13884), and if you click one of them you can download a tool to check the hashes of the files you downloaded. Re-download any that are different from the hashes posted.
     
  11. Rhys Gardiner

    Rhys Gardiner

    Messages:
    5,364
    Ratings:
    +767
    You know what, I hadn't downloaded any of these packs yet. That might be the cause of the issue. I thought all non-BTB stages were included in the RSRBR download as is. I'll report back once I've downloaded and installed them...
     
  12. Rhys Gardiner

    Rhys Gardiner

    Messages:
    5,364
    Ratings:
    +767
    Well, dammit. That was it. I didn't have the tracks installed, that's why I was getting the runtime error. So simple, I had even done it before... and yet...

    Sorry for wasting your time guys... :(

    [​IMG]
     
    • Haha Haha x 1
  13. Ole Marius Myrvold

    Ole Marius Myrvold
    JWB 96-13 Staff

    Messages:
    6,978
    Ratings:
    +3,214
    Haha!

    Now - does Monte Carlo work for you, or still struggling with that? :)
     
  14. Roy Magnes

    Roy Magnes
    Gentleman Driver Staff Premium

    Messages:
    3,873
    Ratings:
    +1,687
    Nah, always nice to help getting you back out in the forest :)