1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

v1.38 Micro-stuttering

Discussion in 'Stock Car Extreme' started by Chris Stacey, Sep 2, 2015.

  1. Chris Stacey

    Chris Stacey
    Ted Kravitz Appreciation Society Staff Premium Member

    Hello there :)

    I seem to be getting a lot of micro-stuttering on v1.38. They seem to be at one second intervals. It's not a gamebreaking issue as they're quite small, but they're just noticeable enough to be a nuisance.

    I've tried an array of different things like lowering graphical settings, altering refresh rates etc. etc. and so far, only the only thing that has fixed it was when I turned V-sync ON, but, in doing so resulted in a huge amount of input lag, so it's not really a solution.

    My specs:
    • Windows 7 Ultimate (x64)
    • Intel i5 4460
    • 8gb RAM
    • MSI GeForce GTX770 Twin Frozr

    Any help would be appreciated. :)

    On a side note, I do seem to also be having issues with a huge amount of shadow flickering that seems to develop and get worse as the session goes on, and does make the game unplayable.
  2. Msportdan

    @ Simberia @Simberia

    try max rendered frames at 1. either in nvidia Cp or inspector. :)
  3. Fabio Rodrigues

    Fabio Rodrigues
    Reiza Studios Community Manager

    What Msportdan says should help with the microstuttering.

    There's also a temporary fix for shadow flickering: please add "-fullproc" to the game's command line. It's not ideal, but it should work until we develop a definite fix.
    • Like Like x 1
  4. I noticed that the motec plugin causes huge game breaking slowdowns now with this update. Could anyone confirm?
    Last edited: Sep 3, 2015
  5. Morello

    Premium Member

    If you're using f.lux try turning on its Safe Mode. Occasionally it will interfere with games I play such as GSC and CS:GO by causing stuttering every second, because it polls every second to check that nothing has changed the monitor colour profile.
  6. JoelGL

    Premium Member

    Just confirming, is it really "-fullproc", as I've always thought it was "+fullproc". Any way to check my set parameter is working?
  7. Fabio Rodrigues

    Fabio Rodrigues
    Reiza Studios Community Manager

    Yes, it's -fullproc because what it does is set the game to use only one core instead of all your processor cores. That's why I said it's a temporary fix - it does fix shadow flickering, but it means you might lose overall performance.
    • Like Like x 2
  8. Chris Stacey

    Chris Stacey
    Ted Kravitz Appreciation Society Staff Premium Member

    Thanks! That fixed the shadows going crazy :)

    But the stuttering still remains. It's not as noticeable at some tracks like Montreal or Spielberg, but at others like Buenos Aires it's very very noticeable.
  9. Fabio Rodrigues

    Fabio Rodrigues
    Reiza Studios Community Manager

    Hm, try changing time scale to "none", see if it helps.
  10. Chris try the alternate video timing available via this PLR flag.

    Max Framerate="-61" // 0 to disable, for regular exe only, see multiplayer.ini for dedicated server framerate, new: use negative values for alternate timing
    I have a 60Hz monitor... I set monitor refresh +1 frame, and with my system the alternate timing shows improved performance. Many users report improved (micro stutter) performance by using vsync.
  11. tpw


    Just a thought, are you using reshade or sweetfx? Any enabled SMAA/FXAA fx cause quite bad track dependent microstuttering every few seconds on my rig.
  12. Do not add 1 frame to your framerate or you will have a constant stutter over and over and over again because the game is outputting 1 more frame than your monitor outputs, constantly, over and over again. Set that number to the same number the game's refresh rate is set to. Make sure to put the negative sign in front of the number (e.g. -60, not 60, or -100, not 100, etc.). It may be different in Gringo's case (regarding the extra frame) because he is using vSync, but without using vSync, it will add a constant, non-stop stutter/hiccup/frame-skip. Speaking of vSync, I highly advise against the use of vSync or any form of "sync" for simracing (but I love it for just about every other game) as it adds input lag, on top of that, as others have suggested, make sure to set max pre-rendered frames to 1 as that will lower input lag further.
    • Agree Agree x 1
  13. Msportdan

    @ Simberia @Simberia

    disagree with the disabling of sync, in my case in every game/sim i get screen tear, which hurts my eyes after a while.
    • Agree Agree x 1
  14. Chris Stacey

    Chris Stacey
    Ted Kravitz Appreciation Society Staff Premium Member

    I've also noticed that my configuration tool doesn't appear to save the settings that I give it.
    For example I tried setting the resolution to 1920x1080 and then the refresh rate to 59Hz, then clicked okay. I then opened the config tool again just to check that it had saved, and it had reset to 800x600 at 56Hz
  15. JeffL

    Right on Brother, I hear ya, it's all good. Premium Member

    Open the config tool as administrator or change the permissions
    • Beer Beer x 1