1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Unable to play

Discussion in 'Stock Car Extreme' started by reborn67, Jan 26, 2014.

  1. Hey Drivers,
    I am trying to play GSC 2013 on Windows 8(no updates) and I completely install all components on drive C. I use Admin and compatibility XP mode and the game will play all the until I try and choose one of the choices such as single day, test multiplayer, etc. I suppose a choice is supposed to be visible on the menu screen because there is a arrow on both sides and nothing in between. I run Assetto Corsa RBR2014 and LFS perfect. It is like it is not loading the maps or cars and it crashes when chosen. After choosing, it freezes the game and I Alt-Del out and it shows a crash icon with a dump file. If anyone could help, it would be appreciate. Thanks
     
  2. I'm not familiar with Win 8, but you shouldn't need to be in xp mode, it is a game designed for Windows 7.

    So you can get to the main menu, but not select test day/championship etc?
    First I would recommend installing outside of program files folders, so for example C:\GSC2013 or C:\games\GSC2013 would be good.
    Second, turn off any antivirus software running in the background when installing and running to see if that cures it.
    Also, have you run GSC config? Go to the main GSC folder and run GSCConfig, then set the graphics and everything at the lowest settings before running the game. This might help get you started while you work out what is wrong.
    Also, right click on the game icon and 'run as administrator' if that option still exists in Win8.

    I hope one of these fixes it :)
     
  3. Matej Lakota

    Matej Lakota
    Sriple Tix Premium Member

    I have W8 instaled on C:, GSC2013 on D: drive and everything works fine, so I guess, W8 is not a problem here.
     
  4. Thanks guys for your help so far. Yes Keith, everything you described is correct plus, I did put it in C:GSC2013, gave it admin rights and turned off AVG. As far as graphic settings, I applied them this time to the lowest and that seemed to work. LOL, if that was the problem. Thanks again