1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TrackIR trouble

Discussion in 'RaceRoom Racing Experience' started by Richard Eriksson, Mar 4, 2016.

  1. Anyone except me having trouble getting a smooth panning with TrackIR?

    I use TrackIR5 with TrackClip PRO and it seems like when i pan around, it stutters like crazy, most of the time.

    Looking at the tracking software i get smooth 120fps tracking with no interference all the time, but in RRE it stutters like mad when looking left and right. Like it also does in rFactor 1 AND 2 incidentally.

    Notable is i run RRE VSynced at solid 60fps. TrackIR software is latest official version and drivers, on Windows10.

    I have accepted the fact that rF2 is unusable with TrackIR due to stutters, but will NOT accept it for RRE, my goto sim...

    Could try to take away the VSync/capping in RRE but then again, if i do i get so many frames on this rig that the stuttering and tearing is horrible on my 60hz monitor.

    Any ideas? Any other TrackIR-users that have managed to get it smooth?

    For reference it is completely smooth in Assetto Corsa, Euro Truck sim etc.

    rFactor-titles i know not to work ok, as well as IL-2 Sturmovik where the same panning stutter occurs, and also RRE apperantly.
     
  2. Did you try a different USB port for the IR camera?
    I'm using FreeTrack myself and when looking around in R3E it is less fluent than in Race07 and SCE, but I does not stutter. I do have v-sync off though.
     
  3. Yep. Looking at the camera in the camera view of the software while playing, shows solid 120 fps capture, no problems or interference.

    It pans fine for a while, then stutters, then fine, then stutter etc.

    Same as IL2 or rFactor used to do when i used those sims. Assetto Corsa and Euro Truck Sim are fine, with solid smooth panning...

    Even when VSynced. I need to keep VSync on as the incosistency of frame times otherwise makes me sick and detracts from the experience for me,,,
     
  4. TrackIR works fine for me in all sims. Are you sure you don't have a bright window or something behind you? That will cause problems because it confuses the sensor. Also have you tried using the basic TrackClip on its own to see if that works? It could be that the TrackClipPro is playing up. Personally I never bought the TrackClipPro, I just use the basic one on a baseball cap and don't have any problems. Have you ever had TrackIR working or is this a new problem?
     

  5. Been like this all the time. As i said, i am sure i have no interference, looking at the camera set-up in TrackIR while playing shows that tracking is 120fps, no extra lights being tracked.

    rF2 shows same issues, as does IL2.

    Tracking however works flawless in Assetoo Corsa, Euro Truck Sim, Elite Dangerous, Rise Of Flight etc.

    Same light conditions and position.

    With or without PRO clip makes no difference either.

    But to compare, what are your other specs? If it works for you in RRE? I am running 6700k I7 with hyperthreading and Windows10, TrackIR5 and i always have VSync on. How does that compare to your setup?
     
  6. My specs: i7 2600k @ 4.2 GHz, 8 GB RAM, nVidia GTX 970. R3E running at maximum graphics settings, but only 2x AA, FXAA turned on, vSync off.

    Just for testing: does it stutter when you turn down the graphics settings (say low or medium)?
     
  7. DrDetroit

    DrDetroit
    Premium Member

    I have no stuttering either when panning with TrackIR in RRRE or any other sim I run (DCS world, Falcon4.0 BMS, F-1 2014 and 2015, etc). I do not run Vsync. I use both the hat clip and Track Clip Pro without issue.

    AMD 8320 8-core, 2gb GTX750, 16gb RAM - running all settings at max.

    Good luck!
    DrDetroit
     
  8. My specs:
    i5 4670K @ 4GHz
    HD7850
    8Gb Ram
    Windows 7

    In racing games I rarely use vsync. The only time I can remember using it was in the codemasters F1 games but that was because of the FFB glitch without it. My only use for vsync is sometimes in offline single player games because of the smoothness when you don't need fast reactions against AI.

    I would suggest testing without vsync. It's odd that for me it always works fine. I can't say I've had a single glitch in the whole time I've used it.
     
  9. Hmm... Can you guys try with VSync on? Just to see if it introduces it for you? I have a theory as to what is going on, that i might bring up with NaturalPoint..

    And how on earth anyone can stand looking at rendered visuals without vertical sync is beyond me, it makes me physically sick :)
     
  10. Yes, it always stutters. Turning off VSync seems to help though... But then i get 200+ fps at max settings so i get horrible tearing and jerkyness that makes me physically ill instead, so that would be no option.

    See above, please try to turn in-game vsync on and pan around with trackir, see if it introduces the issue for you as well. For me just standing in the pits and looking around causes it to start after a while.
     
  11. Spaldinio

    Spaldinio
    Premium Member

    Hi Richard

    I use trackir5 and experience stuttering mainly with RF2. R3E is OK for me, but it does stutter from time to time, usually when moving back to default position. RF2 is the worst culprit, being very choppy no matter what I try - I've seen a few similar posts but not many. I use vsync (for 60Hz monitor) with most games, but I've tried all combinations in search of buttery-ness. NaturalPoint are waiting for a video capture from me to demonstrate but I've not got around to it yet. Stuttering is the quickest way to pull you out of the immersion of any game...

    Post an update if you solve the problem - likewise I'll do the same.

    My specs:
    i7 3770k OC 4.5GHz
    16GB ram
    gtx 970 overclocked