• “Just being a mediocre driver has never been my ambition. That's not my style” ― Michael Schumacher
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Thrustmaster TX

Discussion in 'Sim Racing Hardware' started by stuuuj, Jan 25, 2017.

  1. stuuuj

    stuuuj

    Messages:
    4
    Ratings:
    +0
    Hi all,

    have had my tx base + im currently using a 599 wheel which i've had for about six months.

    started off fine but very often now im losing FFB, sometimes I don't even get it at all when I start up, im guessing it could be the base on the way out? I have tried changing to forced cooling, that doesn't achieve anything really :(

    When I was playing before (assetto mainly) I would turn my FFB upto about 120/130, as I really like the very strong feedback - im pretty much terrible without it. Is this the probable cause of the clipping?

    Lastly: I only seem to get this strong ffb and I currently play on 270/300 degrees of rotation, as i dont like playing with a big rack, to get more of the race car kind of feel. I've turned this way down on DIRT rally too but for some reason i dont get any FFB on that at all.

    If anyone can suggest anything that would be great.

    thanks
     
  2. Wicked

    Wicked
    Horsepower! My kingdom for some horsepower! Premium

    Messages:
    165
    Ratings:
    +124
    I'd open it up (doesn't void warranty and is relatively easy) and check if the belt is still tight and if the motors engage when you use it.

    Could be various things. I personally always advice against running TX / T300 on maximum power because they don't do well under high stress it seems. If you want more power a wheelbase with more nm of power is a far better buy for you. You seem like one of the few scenarios in which I'd say a T500 is better, it's more 'brutal' and strong, less refined. But since you love high FFB and don't care so much about detail (considering it's clipping).

    Does it actually overheat?
    Also drop Thrustmaster support a email about it.