1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Thrustmaster T500RS July 2014 drivers & V42 firmware problem

Discussion in 'rFactor 2' started by Kevin Cox, Jul 19, 2014.

  1. I have just updated my T500RS to the July 2014 drivers and firmware V42. Heads up on firmware upgrade. Don't use USB 3 as it messes up firmware upgrade!!! Use USB 2.0 and all will be fine. [​IMG]

    Now I finally have July 2014 drivers and firmware V42 the Control options menu in rf2 runs very very laggy. Anyone else getting this problem?

  2. @Kevin Cox

    I concur Kevin, there is a problem with the new drivers and rFactor 2, but only with the T500RS. I have no issues with the TX. I just installed the new drivers for my brothers T500 wheel and as soon as you go to the configure controls, it starts lagging badly and becomes almost completely unresponsive. As long as you stay out of the controls menu, it seems to work fine but as soon you as you enter that menu, its screwed until you exit out of the game. Just FYI though, its not the firmware causing it, its strictly the drivers. I ended up keeping the new firmware on his T500 and rolling the drivers back to the 2013_TT4 drivers which work fine.

    EDIT: The problem exists on the TX also, however it doesn't seem to be the wheel that's the problem. It seems to be the new drivers when using the TH8RS shifter. When I encountered the issue yesterday on my brother's T500 wheel, he was using a TH8RS shifter. It never occurred to me that it could be the shifter. I have the new drivers installed on my PC's at home also. I connected up my T500 (no shifter) tonight and it didn't have any freezes, however when I connected my TX with TH8RS, it started freezing in the control menu.

    Kevin are you using a TH8RS shifter? If so, you will have no choice but to roll back drivers until this bug is fixed unless you want to disconnect the shifter for rFactor 2.
    Last edited: Jul 22, 2014
    • Beer Beer x 1
  3. Last edited: Jul 24, 2014
    • Love Love x 1
  4. Yes I do have TH8RS shifter. Thanks for letting me know. I had downgraded my wheel back to V41 so now I know about this I will upgrade back to V42 and update shifter.

  5. Actually there's a new firmware too, v43.
    • Beer Beer x 1
  6. How do you install the package? I screwed up my firmware install when I got my wheel second hand. The guy i bought it off of did it for me.
  7. You install the latest drivers. Make sure Windows has fully recognized your wheel and the bottom right hand corner of the screen isn't showing that Windows is still looking for drivers. After that is done, go to firmware update in the Windows Start Menu in the Thrustmaster folder.
  8. Thanks Blkout.
  9. when I try to load the driver windows says driver not successfully installed.I have win 7 64 bit. i cant go further. great wheel shitty installation
  10. Make sure your not using USB 3.0 as that causes problems. USB 2.0 should be fine. :)
  11. Ive tried every usb port on my comp. 2 or 3 its not detecting the wheel. Ive tried without the pedals attached too
  12. Can i get the drivers anywhere else other than Thrustmaster?
  13. I got it now. I had to use my old laptop with USB 2 . My MB actually does not have USB 2 ports.
  14. Glad you got it sorted Jake. TM really need to sort problem with wheel when it comes to using USB 3.