• You don't get fast in order to take part in club races, you take part in club races to get fast!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dear Guest. Follow RaceDepartment on Twitter, Facebook, Instagram, Twitch, Steam and YouTube.

Thrustmaster T300 Clicking

Discussion in 'Sim Racing Hardware' started by Jesse Rowland, Oct 30, 2016.

  1. Jesse Rowland

    Jesse Rowland

    Messages:
    40
    Ratings:
    +4
    OK, so the title shows what problem i am having.

    It makes a weird clicking noise when i turn anti-clockwise but only at 90 degrees after that it stops. People have had this problem too but no one has fixed it all they say is to send it back. I have already got a replacement for my first because of an offset center.

    It costs me 20 euros to send it back to the retailer everytime so im looking to see if any one on here had this problem and knows if theres a fix for it? Also what the cause is?

    I've contacted Thrustmaster myself but they havent replied to my ticket yet.

    Thanks
     
  2. PicoBp

    PicoBp
    #26 | HSRC - Banzaaaiii Touring Car Crew Premium

    Messages:
    748
    Ratings:
    +436
    Offset center can be recalibrated easily, did that with my TX. For the clicking, is it a 'clunk' at around 90 degrees both sides that you can feel as well? If so, it's probably the motor bracket screws being loose, or the belt tension needing adjustment.
     
    • Agree Agree x 2
  3. Jesse Rowland

    Jesse Rowland

    Messages:
    40
    Ratings:
    +4
    No i didn't know that at the time, and the clicking i can feel ever so slightly theres not really a clunk feel or sound to it. It sounds like scrunching a bag of crisps just not as loud. Is it something i should be worried about?
     
  4. Matt88

    Matt88
    Team Manager and Driver - MK Simsport Premium

    Messages:
    130
    Ratings:
    +47
    Hi Jesse,

    I have the same thing on mine. Now I only notice it when I rotate with the wheel and PC turned off.

    Concerned me at first, have learnt to ignore it and everything is still working 6 months later.