1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TH8RS not working with GSC2013

Discussion in 'Stock Car Extreme' started by Mike Bruce Smith, May 7, 2014.

  1. Hi All

    Pretty new to all this stuff so hopefully I can explain my issue as clealy as possible.

    I have a T500RS Formula F1 Wheel and have just added a TH8RS shifter. I am using TH8RS in sequentional mode. I have succefully installed the shifter to RF2 & AC but i'm not having the same luck with Game Stock Car Extreme. In RF2, the shifter in game is mapped as JOY1B9 & JOY1B10. The Wheel & Pedals were originally mapped to JOY1 but are now mapped to JOY2*** for each function (wheel/pedals etc). Everthing works fine. Same with AC, no issues.

    The problem i'm having is with GSC2013. After I load a default or any controller setup, and then try and map the buttons for anything, it defaults to JOY2B7 for any function I choose. Whether it's the brake or LCD, any function, I only get one choice. In the Thrustmaster Control Panel the number 7 button lights up whenever you first touch anything, like the wheel, pedals or buttons and stays on. You can still select all the indiviudal buttons and they all light up correctly, but button 7 stays on.

    I have unplugged, restarted, etc etc but still no luck.

    Thanks in advance.
  2. Andi Goodwin

    Andi Goodwin
    Premium Member

    looks like you have a sticky button , give it a wiggle throw some compressed air at it ; if all fails get a copy of diview and kill the button and then set up ingame

  3. Thanks Andi

    Not sure on the sticky button. It works fine on rF2 & AC. The wheel and shifter is only a few days old.
  4. Mine works fine. All I had to do was go to the control setup and assign each gear to the TH8RS, which means I had to go through all of the gears one by one and assign them accordingly. I wouldn't think it would be any different for sequential mode, but it does sound like maybe one button is stuck.
  5. I had the same problem (looked like a button was stuck). The issue was I did not have the latest firmware installed. Mine TS500Rs is working fine now with Firmware level 41.
    I dont have a shifter but the symptom sounds the same.
    Go into the control panel and check for an update and see what version you have.
  6. Thanks Rick

    Yes the firmware is up to date. I forgot to mention that with the shifter plugged in, the control panel/rates section shows the accelerator, clutch and brake as Fully On. So if you enter the game the engine screams at full throttle.

    I'm at a lose to understand.
  7. I read your initial post and you say, when you load the default or any control setup, you have this issue, but let me ask you this. If you remove the TH8RS, does everything function just fine in the GSC?

    Have you tried creating a completely new custom profile and mapping all of the buttons that you want to use, including the shifter? Have you tried the recommended profile for GSC from Thrustmaster?

    Game Stock Car - Ferrari F1 T500_01] 639 KB

  8. If none of this works, I'm inclined to believe you have a bad shifter. I've seen this issue before on forums and it usually turned out to be a bad shifter.
  9. Thanks Blkout

    Yes the wheel works fine in GSC without the shifter connected. It's only when the shifter is connected that the issue occurs. I raised the problem with the Thrustmaster retailer but as the shifter works fine in both rF2 & AC they say its not a product issue but more likely a sofware/game conflict. I will try your suggestion above (tonight) and report back on the result.

    Cheers Mike
  10. It does seem strange that its only affecting GSC and logic would say it has to be that game, but it appears that for some reason, the game is receiving a signal from your number 7 button on the TH8RS which is seventh gear. In sequential mode it should only have buttons 9 and 10.
  11. In the Thrustmaster control panel for the shifter....it shows the buttons 9 & 10 operating correctly. When you change to the wheels control panel the 7 button lights up and stays on, even if I turn the wheel left or right.

    If I go into the games contols sometimes the SHIFT up & SHIFT down is already selected to JOY1B9 & JOY1B10, however as I said before the control panel/rates section shows the accelerator, clutch and brake as fully on. If I try to change the pedal allocation if defaults to JOY1B7 and every other selection defaults to the same, leaving the prevoius selection now EMPTY.
  12. I might take some screen shots tonight of the control panel for both GSC & rF2 so you can see first hand. Thanks again
  13. Mike, button 7 on the wheel is different than the shifter so if you're seeing button 7 stuck, then it seems like the rim has an issue. I don't have the F1 rim so I can't tell you which button it is but you can go through them one by one and see which button is stuck. It might be nothing serious, maybe a can of compressed air might unstick it.

    Are you using the latest firmware on your wheel? Should be v41. You can verify it in the top right of the TM control panel for the wheel.

    If the firmware is up to date, I might suggest you remove the rim and just check to make sure there's nothing wrong with the contacts, then try to reinstall the rim and reboot your PC to allow it to recalibrate. Just make sure the wheel is unplugged from the PC and the power cord from the wall as well when removing and installing the rim.
  14. Blkout

    If it was a stuck button wouldnt that affect rF2 & AC?

    The 7 button isn't an issue when the shifter is not connected. It only when the shifter is plugged in that the issue occurs. I also have the 458GTE add on wheel and it happens with it too. I have the latest firmware installed for both controllers.
  15. Mike it may not affect those games if that 7 button isn't mapped to anything in those games. Maybe GSC has that button mapped to something by default.

    Have you tried the TH8RS calibration software?


    If this doesn't work, the only thing left to try is uninstall all the Thrustmaster software and reinstall it again. I assume you're also using the latest drivers from the website. Did you install the TM drivers, then connect the shifter, not vice versa? According the TM, its very important that you don't connect the wheel or the shifter until the drivers are installed first. Seems silly but maybe they've run across an issue if its not done in that order.

    Latest drivers for the T500RS wheel.


    Latest drivers for the TH8RS.


    Oh and there is one more thing to try, silly as it may seem. Have you tried connecting your wheel and/or your shifter into different USB ports than what they're in now?
    • Like Like x 1
  16. I will give all of these things suggestions a go when I get home from work tonight. It's still a mystery especially when they work faultlessly together in rF2 & AC.
  17. One last question, does this happen in H-Pattern mode too? Or just sequential?

    If none of these work Mike, its time to get another shifter I'm afraid. The TH8RS is a great shifter and I rarely read about problems with them, but sometimes you just get a get a lemon or its possible you might have gotten a return.

    My name is Mike too. :thumbsup:
  18. Hi Mike

    I'm not sure about the H pattern. I have only used it in sequential mode.
  19. Hi Mike

    Button 7 appears to be the problem just like you suggested. On the F1 wheel it is the left hand togggle switch (labelled BO). I when through all the buttons individually and that one appeasr to bethe culprit. It seems to be locked on or jammed. Thank you so much for all the assistance, It is greatly appreciated. I will have to take it up with the retailer.

  20. Glad you figured it out Mike. I know that's frustrating. Didn't you say it was happening with the GTE rim also though? If so, I would be more inclined to believe it might something in the wheel base causing it.