1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

T500RS Driver and Firmware Update - 2014-7-15

Discussion in 'Sim Racing Hardware' started by Blkout, Jul 16, 2014.

    • Like Like x 2
  1. Hi,
    today I see that there was a new Firmware for the T500RS V.42. I have updated it but I encounterd some big problems. After the firmware updater finished all my usb port where f***** up. My logitech keyboard and mouse doesnt worked anymore. I had to restart my computer after that everything worked fine. But after driving with my T500RS the problem showed up once again. To solve the problem i have done a downgrade to V.41. Now everything is working as normal.
    Are there some known issues with the newest firmware? Or can someone explain what happend really strange...
  2. I have updated both the drivers(first) then the firmware without any issues, all my usb are working fine.
    I have my T500 to a usb2 rather a usb3 port as I had some strange problems when I had bought it and installed it in to my pc in to a usb3 port.
  3. I've seen some very odd behaviour from logitech wireless receivers recently. I have an MX Performance and T650 touchpad runnign from the same unifying receiver. I've also got a G602 mouse on its own receiver which only a few days ago when plugged into another usb port demanded the pc be restarted before it could function. My Logitech K810 keyboard also dropped off the system,

    What logitech kit do you have. Is it the same as mine. Also how many devices (even non logitech) do you have plugged in. It could be a usb resource issue which I've been fighting myself lately.

    I'll try the firmware update now and report back on how it goes.
  4. @Andre Konetzka

    I didn't have any issue updating my T500RS firmware and drivers today. I also updated my TX firmware and drivers as well and both work fine.
  5. Ok now I'm completely screwed. Firmware update failed, no lights on the wheel and its showing on both my pcs as "thrustmaster trs racing wheel bulk driver".

    Please dear god help. I have no warranty on this thing. :(
  6. Right I'm back up but only after downgrading to the V41 firmware. I cant see it on Thrustmasters website as the usual link only brings you to the V42 page. Here is a link for those that need it.

    http://driverscollection.com/?H=T500 RS&By=Thrustmaster

    There appears to be a problem with the V42 firmware updater. The programs menu see it as a "racing wheel" rather than a T500rs which is possibly preventing the updater seeing the wheel as a device it can update. When the wheel goes into bootloader recovery after a firmware update fails its detecting it but will not allow you to apply a firmware. I'll be speaking to TM tomorrow regards another issue with one of my F1 rims so I'll query them on it or flag them if necessary.

    While V42 might be ok for some I wont be updating again until I'm sure this is sorted or at least a workaround found.
  7. I also updated drivers first, firmware second. Not that it SHOULD matter but I didnt have any issues this way.
  8. Good to hear. Maybe if others are determined to update they should do it your way. Nearly had a Sean Coronary (the Scottish version of a heart attack) when the update failed. Thank god for the V37 onboard bootloader backup or I'd be down a wheel and back to making engine noises on public transport to compensate for the loss of my race addiction.
  9. I would panic too. I hate updating firmware on anything for this reason.
    • Agree Agree x 1
  10. Rupe Wilson

    Rupe Wilson
    Keep Yoga real Premium Member

    Ok i just updated my wheel from the start menu of the pc.
    using the Thrustmaster update service.

    I also have a full logitech system,
    G15,G13,G25,G9 all using the logitech gaming software,
    The only thing i did is exit the software before updating,

    clicked on the Thrustmaster update service, it did the rest all done and working.
    rebooted my pc after is was all finished and all logitech product jumped in to life.
  11. Keyboard is a G510 and Mouse is a G9x all wired...

    I have downloaded the new update. First deinstalled the old and then installed the new one. After that i have rebooted my system and installed the new firmware with the updater. Everything worked fine during the update process. At the end the updater give me the information that everything is done and ok. Then the wheel recalibrate it self like it should but than comes the problem after the calibration.

    My usb goes crazy my mouse and keyboard go on and off (you also hear multiples times the usb sound from windows). When i unplugged the usb devices and then plugged it in it doenst work anymore and i have to reboot my system. After that everything is working as it should.

    I thought everything was okay tested rFactor 2 and drove some laps. But after leaving track (rFactor 2) the same problem showed up with the usb. I also tested some other games and the problem showed up at random points after downgrade everything is working without a problem.

    It is really strange, The crazy thing is that Windows nothing log when the problem showed up about a usb problem. I also deinstalled the Usbdriver and reinstalled them. Really strange... I have no clue and i am very tenical advanced user.
    • Agree Agree x 1
  12. That sounds very much like a usb resource/power issue. Its possible whatever thrustmaster did with the firmware may be causing an increased power draw.

    My thinking is with the focus on the PS4 with the T300rs and making the T500 likely compatible with it TM may have upped the current draw as the PS4 uses USB 3.0 (900mA) versus USB 2.0 (500mA). TM have had problems with USB 3.0 ports on occasion and they may be trying to cure that as if they don't their wheels will screw up when connected to the PS4.

    Are you connecting to usb hubs and are they usb 2 or 3 and are they powered?
  13. Hm thats an interesting theory... All my input devices are directly connected to my mainboard (USB 2.0) no front usb, no hub.
  14. I've seen a lot of posts about USB hubs being the devil when it comes to using a wheel but its my opinion that a properly powered USB hub shouldn't be an issue, in fact, it might even help if you have problems with your USB ports not providing enough power for your devices. When it comes to wheels though, I don't think the USB port is providing any power to the wheel, its just sending and receiving the signal to and from the wheel as to what is going on. The wheel has an external power source.

    There are cheap USB hubs that don't have much power and can cause problems and there are quality hubs that have enough power to run multiple devices without any issue. I had been avoiding a USB hub for my wheel for 6 months and I finally decided I would try one so that I'm only using one USB connection on my PC and to my surprise after hearing so much talk about how hubs and wheels don't play well together, I've had no issues with this hub. Its worked flawlessly for the last month and a half, even during the update process.


    And FWIW, I've used the front USB ports on my case with my T500RS plenty of times on my HTPC and never had any issues there either although I've often heard people complain that you can't use those ports with a wheel. I've never understood that but I suppose some people have had issues, likely depends on the motherboard being used more than anything else.
    • Agree Agree x 2
  15. Just 2 days ago I received the USB 3.0 version of that hub you bought. I ran it last night with the T500rs (before & after I bricked and unbricked the wheel) and its been running perfectly. Love the rubberised finish, build quality, low profile and the switches are great to ensure unnecessary devices causing draw or conflicts can be disabled. Had to look long and hard to find a seller. A good quality USB hub is often better than some onboard USB ports. I bought mine from these guys.


    Word of warning to others reading this. TM state DO NOT ATTACH THE WHEEL TO A USB HUB TO UPDATE THE FIRMWARE. Its not them being picky. Connect directly to a USB 2.0 port if you have one.
    • Agree Agree x 1
  16. My hub is USB 2.0 and my updates went just fine. That gets back to what I said before, I'm sure there's a difference in quality among hubs but ultimately, nothing about a hub itself SHOULD cause a problem, its just passing a signal.
  17. Joel

    #NR6 Premium Member

    You are having the 1:1 issue as I am. How do you downgrade the firmware?
  18. I am not alone :) You need the 2013_TTRS_2.exe (When Thrustmaster has no download you can google it or i can upload it for you). When you start it will automatically deinstall the new version. Then execute it a second time and it will install the the old version inclusive the V.41. Then run the Firmwareupdater and you should see that your wheel has V.42 and that you now choose V.41. Run it and everything is working.
  19. Joel

    #NR6 Premium Member

    Do you have useful link for that piece of software? :)