1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

T500 Dead :(

Discussion in 'Sim Racing Hardware' started by Craig Stevenson, Feb 1, 2016.

  1. Hi,

    For the last week or so my T500 has been acting weird, when I booted up instead of rotating left\right and then centering it would just keep spinning (varying degrees) left and right, some times it would be corrected after I swapped the ports (I was using a USB 3.0 Hub). Over the weekend I rebuilt the rig with a new Z170 Mobo and the problem remained and it remained whether it was connected to the USB 3.0 Hub, USB Ports on the back plate (USB 3.0) or the ones on the front of the case (USB 2.0), I just thought I would check the firmware was up to date, the updater couldn't find the device and came up with an error code (forgot hat it was) but since then it won't even power up (no power light) but it is still detected, I get the ding-ding when connecting\disconnecting it, although this is probably for the Pedals isn't it?

    So question are 1) anyone experienced anything similar and know if I can boot it back to life somehow and 2) how good are Thrustmaster Customer Service, when my Logitech G25 failed after well after 3 years they just sent me another one as long as I cut the USB plug off the old one and sent it back. I've put a Ticket in with TM asking their advice.

    If TM won't play ball and replace or repair it:
    1) Can I buy just the T500 Wheel anywhere (UK)?
    2) Would you get another T500?
    3) I really like the T500 Pedals so would definitely want to keep those, would look at the new Logitech wheels but which is the best one for PC, G29 or G920 and can I use it with the TM Pedals?

    Regards

    Craig
     
  2. Caramidaru Andrei Bogdan

    Caramidaru Andrei Bogdan
    Mr. C Premium Member

    Mine is going also, when it gets heated the cooling fans make a spitfire like noise that ain't good I guess... My experience in Belgium with thrustmaster wasn't as smooth as with Logitech, when it goes I will pay extra for fanatec. Have the v3 pedals and omg what a difference, luv them
     
  3. I have power again, I connected it up to the Laptop which it has never been installed on, I installed the Drivers first as usual then connected up as per the usual procedure but STILL no power light, I then did the Firmware update procedure again, it found the Wheel and went through the Firmware update which appears to have been successful (stage 1 & 2), the wheel has powered up again BUT it FAILED the final check (stage 3) with error code 0x34100002 (see pic), Time Out so I'm guessing the USB Controller has failed maybe?

    Capture1.JPG
     
  4. Tried another Flash after I got the wheel to settle down and it successfully passed all three steps but still rotating like crap whenever it's plugged in. Capture3.JPG
     
  5. My condolences.
     
    • Like Like x 1
  6. I'm not sure of the point of them saying "please write down this error message and visit the page" which is the PDF manual, as far as I can see (I've done a search) there is no reference to that error code or anything close to it in the manual!

    The only reference I can find is "If the firmware update procedure has failed or displays an error message, please contact Thrustmaster technical support, who will guide you through the entire process to follow"
     
  7. Video of what happens when it's plugged in.
     
  8. I wouldn't hold its funeral service just yet, I've had problems with the G25 which was, in the end, just a case of installing the Logitech 'profiler on Windows 7 comparability mode. I've posted about that today, could doing the same with the Thrustmaster software help, maybe?
    The wheel behaving weirdly does resemble, but is different to what I got, but could it be the wheel being recognised as a game controller and then just bouncing on what windows is reading as a simple analogue, lower resolution, joypad input? ie, ignoring the Thrust master software?
    I spent some time hunting the net for a solution to my G25 problem, and whilst I'm not that knowledgeable, I do have a feeling that some Windowsv10 update to either its 'controller interface' or USB or USB 3 software has changed something thats related to strangeness on peoples wheels?
    Also this thread might be worth a look ;
    http://www.bosra.uk/mobile/forum/viewthread/m/28629309/id/23692655-windows-10-aaargh
    Finally I hope and wish you good luck in bringing your wheel back to life.
     
  9. I dunno mate, it starts to calibrate during or just after POST so before any Windows Drivers are loaded.

    Thrustmaster replied to my Ticket with the following:
    To solve this problem try connecting the unit in slow calibration procedure, as indicated here:

    http://ts.thrustmaster.com/download.../T500RS_AutoCalibration_Centering_Process.pdf

    I have set it to slow calibrate and it does seem to have behaved since, it was working perfectly fine in normal calibration mode so WHY all of a sudden has it become necessary to use slow calibration mode?

    Prior to getting the above reply I uninstalled the software, cleared ALL hidden devices in DM and then cleared out the Registry, there were some Registry entries which I thought sounded a bit odd, Microsoft BULK Driver or something like that, didn't sound like a driver from TM.

    One thing that sprung to mind from seeing the "MS BULK Driver" entries was that the TM drivers should be installed without the wheel being connected, the wheel should be connected when instructed, now before I rebuilt my rig I had Windows10 set to receive Insider Previews and the wheel is always connected which means Windows has basically done several installs with the wheel connected, however as I mentioned above I still think the problem starts before any Windows drivers are loaded, I need to investigate this a bit more.

    Regards

    Craig
     
  10. To answer your 3rd question, don't get the g29/920, it will just disappoint you. It's just a g27 with more buttons into it and 2x the price...
     
  11. I had this very similar problem. In my case it was with a G27. MY fix was 2 fold. #1 It didnt like USB 3.0 ports at all, no matter what. #2 A POWERED USB port solved my issue as for some reason it simply wasnt getting enough juice. Not saying this is your problem, but maybe have a look in another direction? Cheers, hope you get it going.