1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Streaming lag

Discussion in 'rFactor 2' started by stop, Dec 19, 2013.

  1. I'm trying to livestream rFactor 2 with Open Broadcaster Software, but there is a lot, I mean a lot of lag! I've tried everything, turning the settings down, turning the graphics down, and still no luck. I tested it with rFactor 1 and it works without lagging with OBS fine.

    Any help would be appreciated.
     
  2. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Got enough upload speed?
     
  3. The lag is not on the stream, the lag is on my PC, as soon as I click Start Streaming, the game starts lagging a lot!

     
  4. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Ah ok, but without a detailed list of specs its pretty hard to help :)
     
  5. My computer is an 8GB RAM HP Windows 7, I have put the settings to as low as they can get, but still no difference.

     
  6. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    And the videocard?
     
  7. Marco Bijl

    Marco Bijl
    adMAXIhater (O.O.O.)

    Do the following please.

    Start all software (do not start the broadcast yet)
    Right click on your task bar
    Select Task manager
    Click on tab Performance
    Write down what your average CPU load is (just about), when NOT running stream on, but WITH the game running.

    Next, click on Start Streaming on OBS.
    check again, and look at the perfomance.

    I suspect you are going over 85 / 90 % CPU load there. That causes your lag in the game. The computer can't do all the needed calculations to get you on track.

    To optimize, play with the video encoder settings a bit.
     
  8. Yup that's exactly what happens, I already tried that yesterday.

    Graphics card is AMD Radeon HD 6520G

     
  9. Marco Bijl

    Marco Bijl
    adMAXIhater (O.O.O.)

    So, what happens is that you overstress your computer. This causes rfactor2 to lower the number of physics calculations it makes, because it's denied time from the processor. And that causes the lag you see.

    To avoid, start looking for the CPU eaters. Look in your task manager which processes require CPU, that you do not need. Close programs like FRAPS, SKYPE and all other you do not need when broadcasting.

    I use a quadcore 3.4 with 12Gb of mem. It seldom reaches over 5,5 Gb of ram, but my CPU is what I need to watch constantly. I also noticed that the last update of OBC seems to require more CPU.

    Ow, and mind that I am talking about your CPU, and not your GPU (Graphic Processor). Its CPU thats causing issues, not the graphic card.