1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[Solved] Getting Online

Discussion in 'rFactor 2' started by Steve Garner, Feb 22, 2015.

  1. Hi All
    I wondered if someone could help me I have put a post in PrestoGP thread under help posts about trying to get online to save re posting it here if you could look and offer further advice would be grateful have answered some questions from David who has been trying to help but it has been on there since Friday and he was the only one to offer help today so I thought about a wider group might help me many thanks or suggest other things to do
  2. jimortality

    Premium Member

    What exactly is your Issue Steve? I'll have a look on Presto
  3. jimortality

    Premium Member

    All I can suggest for now mate is to try the other racedepartment.com servers and see If you can get on them and download the mods on there. I've never been on the Presto server so I'm not sure what the problem is. Do you need a password for Presto?
  4. Hi Jim
    Thanks for taking an interest in this yes you need a password for presto which I know but not getting that far as you will see in presto thread say mod not installed but everything is ticked in mod manager probably some silly little thing I am not doing that is stopping me but I cannot find out what it is at the moment have tried this afternoon to go on the fun day server by downloading the clio cup and installing that but still says mod not found have used default folders so it should find everything. also on another note hope you are getting better as well
  5. jimortality

    Premium Member

    Thanks Steve, yes it's amazing how proper sleep helps. I don't know then about the mod issue, If I have problems, it can take a few attempts but you're having issues on all the RD servers? How about trying a public server just to see if you can get on that one.
  6. Yes know what you mean when I do earlys have to make sure I go to bed earlier than normal otherwise middle of the week and I can get irritable. Back to RF only thing I did wonder is at the bottom of the screen were it says join it says local host but guessing by it actually connecting to server and saying mod not installed that is ok. have been downloading different cars and installing them and going to try different servers if I can. Will see how I go but I am wondering if it is more to do with directories with it not finding the mods when they are installed but looked through forum and Working one is documents\rfactor2 and packages one documents\rfactor2\packages thanks for help as well
  7. jimortality

    Premium Member

    I'm at work now bud but If you haven't got it resolved by the time I get online tonight about 8pm I'll have another look but my limited knowledge is running out now I'm afraid lol
  8. That's ok thanks off on console later but will look after that
  9. David Turnbull

    David Turnbull
    PrestoGP Veteran

    Hi Steve, sorry you haven't got this resolved yet, Ive been really busy with moving the server to our new dedi and the porblems that brings, will carry on the help here though so you get more exposure.

    The content bit you mentioned in the Presto forum, when you open the launcher and go to the open box, those are installable componants hosted by ISI those aren't what is actually in your system packages folder, you open mod manager for that after youve put the file in the packages folder, so for instance, download sao paulo, put the file in document/rfactor2/packages, then open mod manager and instal the sao paulo file, now its installed ingame, same with the Renault3.5 mod and same with the othe tracks in the rotation.

    The Presto servers have Sao Paulo(Interlagos) Silverstone (Latest version) and Malaysia, if you have those 3 installed then all you need is the Renault3.5 and the vmod which you already have (prestogp 21).

    Is this a new instal of Rf2? have you used it before?, been on other servers? is the game activated?.

    Hopefully we'll get to the bottom of this soon :)
  10. Hi David

    Thanks for reply guessed you was busy sorting servers out after the problems with test race I installed it when rfactor2 first came out and bought lifetime then but at time found didn't have much time to go on so got my money back and happened to go on last weekend and see you was on it now so decide to buy again downloaded what I though I needed and updated everything log on rfactor and it came up with my name so took it was activated tried offline and did a few laps (not very good) and tried to get online and had the problems and everthing thing as far as I can see is installed in mod manager. I am at work at the moment but was thinking of trying to uninstall and do a fresh start and see if that works. Just looking on forum to see what I need to save. Will sign in again when I am home later on
    Thanks again for your help
  11. Sounds like you haven't clicked Join to download the vMod yet. It will show Mod not installed until you do that, unless you got it manually from somewhere.

    Just try this:
    1. Select server
    2. Click Join
    3. Enter Password
    4. A short download will commence, which downloads the vMod, which is a 500-1000KB file which instructs the server that you have all the content installed.
    5. Your server list will refresh again when it finishes. You may need to click on a different server name first, and then click on the server you're looking for, in order to be able to select it.
    6. Click Join again, and enter password. It should work now.
  12. Gijs van Elderen

    Gijs van Elderen
    Premium Member

    A Vmod = 117kb since build 860. ;)
  13. Hi Ho3n3r
    Thanks for replying but mods are already installed when I click on server I want to join it comes up blue mod not found and when I click on join it just makes a noise like maybe not working? I am signed in on rfactor think I am going to have to uninstall and re download rfactor and then try again. Connection must be working for it to check presto server and say mod not installed if I am correct
    Thanks again
  14. Mods and vMods are a bit different.

    But if it doesn't work, yeah, the admins of the server might need to look at it.
  15. Point remains the same. ;)
    • Agree Agree x 1
  16. Don't think its got to do with admins of server others seem to get on ok
  17. David Turnbull

    David Turnbull
    PrestoGP Veteran

    just noticed that the vmod we are using is diffrent to the one you are trying, it used to be prestogp21 but is now prestomix2, getmod works on the server so it should auto download for you, not tonight though as the server is passworded for a test race.
  18. Gijs van Elderen

    Gijs van Elderen
    Premium Member

    PrestoGP Experimental doesn't work for me.

    - Check list for you:
    - The Vmod doesn't contain any spaces
    - The Vmod is in the correct servers packages folder, and installed from that packages folder. (I think this is the problem)
    - There are no "Ghost" rF2 servers (low on RAM) running in the background in the windows task manager.
    - The HTTP port is open and firewall is open for rF2.
    Schermafdruk .jpg
  19. Hi David
    Thanks for that have uninstalled it and am now going to reinstall Rfactor2-contentbuild 930 and will try another server think there was clio cup will look at that to try when did it change though because have been trying for a week and also couldn't get on others. Did notice earlier before uninstalled when I went on presto quali 2 black boxes came on screen one looked like it should have password typed into it and another sqare one on left just above but had nothing wrote on it took it that was supposed to be where you connect?

    Ho3n3r perhaps you were right on presto one but doesn't explain why I got the same on the others? will see when I reinstall

    Thanks all for trying to help
  20. Gijs van Elderen

    Gijs van Elderen
    Premium Member

    @Steve Garner ,

    Once you have everything installed again: try to enter one of the "ISIO" server.
    Those servers are setup by ISI (rFactor 2). So they are OK.