1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Sketchup - problem importing terrain from Google Earth

Discussion in 'Bob's Track Builder' started by lakimakromedia, Feb 15, 2011.

  1. Hi,
    today i wanna import terrain from GE to sketch, and something strange happen, fisrt cupture of image tarrain is ok, and in second I cant take picture, because window with location is empty white ! Somebody know why ! ?

    I wanna make some tracks, and now i have no fundamets for it o0.

    Greatings
    laki
     
  2. About what i talking
    [​IMG] [​IMG] [​IMG] [​IMG]
    On fourth screen You can see blank window
     
  3. This must be something from outside, since I have exactly the same problem... I can grab just one part of the terrain and when I attempt to get "More Imagery" - all I see is that blank white window...
     
  4. i didnt know this was even possible :D grab a part of earth and import to su?
     
  5. i tried and my does exactly the same
     
  6. This is strange - it had to happen within last two months - I had no problem like this when I was making my recently released track - I used two terrain squares there...
     
  7. i needed to save on square and open an new SU window do the other square and imported the saved one and it worked :)

    but the textures are not power of 2 :(
     
  8. Yes, but it's hard to find a new grab place that would be fit good to previous. I also think it's only one solution for now. The textures are jpg's and really low resolution. They don't need to be powers of 2 (because of jpg format). They look bad and blurred in btb/games. I tried to make better screenshots form GE, but most areas (including Poland) are not well photographed. So, it works worse now, but it still works. We can still get some terrain shapes ;)
     
  9. but rfactor gives me texture error when i use the textures.....
     
  10. I didn't know that, my fault. I need to learn about rFactor then, because in RBR they can be jpg's of any size. So, I guess when you resize them to proper, they load with no errors? Sorry for messing ;)
     
  11. Hey Guys!, hi Martinez! hi Laki!!

    Laki, this is what hapen to me last days, do you remember? we talk this last time we chat, i found a ANSWER from GOOGLE i put de LINK

    http://www.google.vu/support/forum/p/sketchup/thread?tid=51b5b127826c07bc&hl=en

    There i write and GoogleTeam say in 10 days that will be solved, but im waiting and nothing happens, maybe it only wait, its frustrating to me but i have to export one mesh at once and join in 3DsMax, its a hard work, but for now its the only way.

    Laki, thanks for be like you are, i have to learn a lot yet, but i think im in the right way, thanks to you i know what i know, im always be happy for know you.

    Martinez, i dont know you but seems like you are a great guy, and Laki trust in you, Martinez! thanks to you too.

    Jose "Envolved"
     
  12. Hi Jose, thanks for digging there! So, maybe good news, maybe less - looks like we have to wait. I knew THEY broke something, not us :p
    BTW, nice to meet you :)
    m.
     
  13. I had instaled Sketchup Pro already and I have the same problem. I hope they will fix the problem in few days.
     
  14. Yeah!! They repair it with realese of new sketchup.
    Now I can work :]
     
  15. Hello people!
    Is there a tutorial as it's working correctly? how do I export from all SU and how do I get it in BTB?

    Greetz from Austria
     
  16. ebrich

    ebrich
    Premium Member

    Just came across this passage from the link below it if anybody is still pondering over the question

    ""Studio Cruz,

    What I said is what should happen in regular installations of SketchUp. There may be something wrong with yours.
    Some users have reported problems with terrain importing on the latest update to SketchUp 8.

    In this case: A model file already has a geo location in it. Users have reported they cannot add more terrain information, they get a blank screen when using the "add location". In that case, one thing that has worked for some, is to go to the model info window ( under the menu "Window-->Model Info) and choose "geo location". Then choose "remove location", then ( in this window) choose "add location". Google is aware of this, and is working on a fix- probably in their next update, but I don't work for Google, so don't know specifics of this.""
    http://www.google.com/support/forum/p/sketchup/thread?tid=5fad224a14ef439e&hl=en
     
  17. ebrich

    ebrich
    Premium Member

    And now I see its already been noted by envolved. Should have read the rest of the forum.
     
  18. I don't have much time to make some tutorial (unfortunately), but after you grab one part of the terrain (it's about 2x2 km), just click "Add more imagery", move the square for the next location and grab. There are some ways what to do next - one is to explode everything you have just got and intserselect together. Then you will get one object finally (with couple textures), but polygons will overlap. They did some better now and it's not really visible too much. So, maybe don't merge these squares, I think...
    Then export as 3ds (since you have SK 8 PRO - it has 3ds export), and xpack the 3ds file adding textures that Sketchup creates. They are small and really low resolution.
    I did it some other way - did not explode, export as 3ds and open in 3dMax - then delete unwanted (overlaping) polygons, make some corrections and merge vertices. After that I mapped the whole thing with new textures. So, maybe the terrain was not real visually, but looked much better.
    If you have problems with 3ds export from SK8, save the file as SK6, open in 6 and export as kmz4. Then the procedure is as known for SK6 - copy the exported kmz, rename to .zip, extract - and load into xpack as collada. Barbje_Keller did a nice tutorial for it in the past. (SK 6 you can find in RD's Downloads).
     
  19. thanxx martinez! I will try this (SK8 -> Sk6 -> .zip )


    regarts from austria
     
  20. Good :) If you have problems - just ask here or send me PM. Good luck!