1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

RSRBR 2011 Crashing in Windows 7, 64 Bit

Discussion in 'Richard Burns Rally' started by Zero7159, Sep 15, 2011.

  1. Zero7159

    Zero7159
    Premium Member

    Hey guys. I bought the original RBR months ago and I installed it over the weekend on my PC in a new folder I created on my HD, C:\Simulations, not Program Files or Users. I am running it on a PC powered by an AMD Phenom II Quad Core CPU, Windows 7 64 bit, 8 GB DDR3 1333 RAM and an AMD 6870 GPU. I use a Fanatec GT2 wheel and Clubsport pedals connected via a USB cable. I forgot to install the two patches (shame on me). I made some recommended changes to the ini file, including deleting Constant Force Multiplier and PC Input. I also changed the resolution. I created the Mulligatawny profile and tried RBR. I could not get any FF in my Fanatec GT2 wheel, but it otherwise worked. I then installed RSRBR 2011, all of the car packs, all of the mods and BTB mods from rallyesim.com. The problem I have now is that anytime I race any car and track via RSRBR 2011, I have FF in my wheel, but the game crashes, sometimes right away, sometimes within a few minutes. I have tried shutting off other programs that are running, including Microsoft Security Essentials, Skype, FRAPs, etc., but nothing works.

    Any ideas? Should I just uninstall everything and then re-install this weekend? Does this sound like a corrupt install of RBR, both because of the lack of FF, but also because of the crashing?

    I have a second PC and I am thinking about installing on that instead.

    Let me know.

    Thanks!
     
  2. Warren Dawes

    Warren Dawes
    Premium Member

    I'd guess that the reason you had no FFB at first is because you didn't install the official patches. They are needed for FFB on later Controllers. RSRBR2011 would have added those for you though.

    Not sure why you are crashing, it could be lots of things.
    I'd suggest trying to run the game from your default RBR launch icon first. This is to check and see if your base RBR is ok. You should also try launching using the Launch Richard Burns Rally button from RSCenter. Maybe also try using the Launch RBR.dll button. These might show where the problem might be.

    Maybe post the contents of your Richard Burns Rally.ini file so we can see the settings. Also, post the contents of your Fixup.ini file (found under Plugins folder).

    I'd also suggest to post at Rallyesim ( http://forum.rallyesim.fr/index.php ), they have a diagnostic tool that can help identify problems.
     
  3. Zero7159

    Zero7159
    Premium Member

    I tried re-installing Richard Burns Rally (just the base, not the RSRBR 2011 and cars) last night. The install went fine. I also installed patch 1.02 (came on the disk and I understand it includes patch 1.01). Well, I have force feedback now, but I am still getting the same crashing problem that I have with my other RBR install on my other computer. Basically, no matter what track or car I use, the game crashes right away or within a few seconds or minutes. Here is my ini file, after the changes I made (deleted constant multiplier; also deleted PC Input file; changed fullscreen to false so I could open window on my 32 inch HDTV and I changed the resolution):

    [Settings]
    Depth = 16
    ForceFeedback = true
    Fullscreen = false
    MinDepthBits = 24
    MinStencilBits = 8
    ParticleQuality = high
    RenderQuality = high
    RunIntro = true
    RunStartup = false
    Sound = true
    UseCubicEnvironmentMaps = true
    UseEAX = false
    UseSoftwareAudio = false
    UseTripleScreenBuffers = false
    WaitRetrace = true
    XRes = 1600
    YRes = 1200

    I could not locate the Fixup.ini file in the Plugins folder.

    I am using a Fanatec GT2 wheel and Clubsport pedals, with the Windows 7 64 bit driver from fanatec.com. I also have an Asus Xonar DG sound card and driver. When Richard Burns crashes mid game, the sound gets all wonky too. Could it be a driver conflict of some sort?
     
  4. Have you tried playing the game with ConstantForceMultiplier NOT deleted? Just a thought.

    Also: can you see any similarities between the crashes? Certain pacenote, going sideways and kicking up much dust, dropping a gear etc., turning the wheel harder than usual, something like that?
     
  5. Warren Dawes

    Warren Dawes
    Premium Member

    Your RBR.ini data seems ok to me.
    Very strange that you don't have a FixUp.ini file? :confused: FixUp.dll should have been installed with one of the RSRBR2011 Updates. Have you installed all of the required RSRBR Updates? See this tutorial:

    http://www.racedepartment.com/richa...ow-play-on-line-how-set-up-rally-on-line.html

    It seems very unusual to have the game crash regularly mid stage, usually if something is wrong, it won't load the Stage. It sounds like a hardware issue or conflict somewhere, but unusual to have it occur on two PC's.

    I'd still recommend asking the guys at Rallyesim, and using their diagnostic tool.
     
  6. Warren, he reinstalled only plain RBR, that's why there is no FixUp.ini :)
     
  7. Zero7159

    Zero7159
    Premium Member

    I found the problem. Both of my machines have Asus Xonar DG Sound Cards in them and so by process of elimination, I figured that must be the source of the problem. When I uninstalled the sound card and driver, and instead used the onboard Realtek sound, I had no problem playing RBR or RSRBR2011. I have all of the updates and mods installed and they run great. That explains why when RBR would crash the sound would get all wonky. Its probably the driver that was the actual source of the conflict, rather than the card itself. The interesting thing is this. The onboard sound in both of my machines sounds better than the sound that I get from the Asus Xonar sound card. The base is deeper and richer and the sound is just more massive. So, this was a double benefit. I can play RBR and RSRBR2011 and I can do it with better sound.

    Anyone want to buy a couple of Asus Xonar DG sound cards? :):):):)

    Thanks to everyone for the advice and feedback. I appreciate it.
     
  8. Tim Ling

    Tim Ling
    It's a million-to-1 chance, but it just might work Premium Member

    Thanks, but no :tongue:
     
  9. Warren Dawes

    Warren Dawes
    Premium Member

    Good work, glad you solved the problem. :thumb:
    I must say though, the one area of RBR that seems sensitive is the Sound management. I've seen, and experienced, a few stability issues with RBR (and RSRBR) that have related to Sound management.
     
  10. Zero7159

    Zero7159
    Premium Member

    Its a shame, because I almost gave up. I was contemplating just uninstalling RBR and putting it on the shelf, but I tried this as my last alternative. I am so glad I gave it one last shot, because it is a great game. I did the BTB USA Pikes Peak track rally race yesterday. It takes almost 20 minutes, but I loved every minute of it. The force feedback in the wheel is superb and the track is good fun. Its amazing this game did not meet better success at retail and that it cost me around $10.
     
  11. Hey, I have same sound card and had similar problems to begin with. Issue solved by decreasing sample rate to 44,1KHz. Now with newest drivers I can keep 96KHz on while I play RBR. You should try decreasing sample rate cause Xonar DG rocks :cool: How can you say some onboard sound is better??? :O Ok if you use something else than headphones it ain't SO MUCH better than some realtek onboard.. But still better. With headphones.. Something different.
     
  12. Zero7159

    Zero7159
    Premium Member

    Its a good question, and I was shocked that the onboard sound was as good as it was. I use the Turtle Beach Z6A headphones, which have a built in amp. So, at least one benefit of the Xonar sound card, the built in amp, is negated by the headphones built in amp.

    Also, the Xonar DG is a decent sound card, but it cost me $15 after rebate. It doesn't surprise me that its not light years ahead of the onboard sound, which comes from new motherboards I just installed in both of my PCs.
     
  13. Headphone amp is best part of DG. Surely got my soundworld up very much! Others like mothers, others daughters like they say ;)
     
  14. Hey everybody (first post in this forum :)).
    I just spend/wasted half my day debbuging this issue in the fun ways there are (opening the PC to check the power connector for the soundcard), restoring windows snapshots, re-install RBR, RSRBR2011, patches drivers, forum reading, etc.). In the end however, I, rather surprisingly at that point, found a solution: open the Asus Control Center (that black/blue traybar icon). In the right hand (you may have to extend the view by pressing the downward facing button) there is a button labeled "GX". It should have a green background, meaning it's enabled. Click it to turn "GX" off. Since the interface spares the user any details as to what "GX" could mean, I checked the manual:

    So, GX is that EAX replacement thing that (according to a thread a read sometime today, somewhere) that was a reverse engineering of EAX, claims at least DirectSound 3D compatibility, but is far from being compatible.

    So, to finally wrap this unnecessarily long post up: uncheck the GX icon the the Asus Control Center and hopefully you'll be as happily racing afterwards as I do.

    Hope this helps.

    P.S. Win7 x64 here, but that seems unrelated as other people had this problem on XP too.
     
    • Beer Beer x 1