1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

Richard Burns Rally lag...

Discussion in 'Richard Burns Rally' started by Nick C, May 19, 2011.

  1. I posted this on RallyeSim but I think it'd be worth posting here too
    Recently I built a new PC, and when I installed RBR and all the RSRBR jazz, my game lags. Every 2 seconds the game will lag for a split second, and it becomes very annoying! What's even more annoying is that I shouldn't be having any problems at all running a game like RBR with my rig. I've tried setting the affinity to just one core, messing with the graphics options, but nothing works. I've been at this for a couple weeks now so I'm hoping one of you here could help me out...

    I also just reinstalled RBR and tried it vanilla and it still lags. I've noticed that scenery density seems to be an issue. On the Newbobs stage, the first section there aren't many trees around so my game runs fairly smooth (though there's still noticeable lag), then when I hit the forested section the lag really kicks in.

    Here's my rig (pasted from the RSRBR tool)
    Processeur : Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz - Nb de core : 8
    RAM : 8GB
    Carte graphique : NVIDIA GeForce GTX 580
    Windows 7 64bit

    As you can see there's no reason why I'm getting any lag at all in this game, I run everything else I have at max settings no problem at all, I'm really perplexed about this. RBR is one of my favorite games and I can't enjoy it on my new PC! :(
     
  2. Using a very similar but slightly earlier cpu and video card with the same amount of ram and OS with no issues.

    Sorry I can't be of any help ther is a new beta Nvidia driver out that fixes some issues maybe try that ?

    http://www.geforce.com/#/News/articles/r275-driver

    Cheers Al
     
  3. Thanks for the quick reply :) I'm downloading the driver now, though one of the first things I tried was update my drivers but at this point I'm willing to try anything
     
  4. There are always couple of possible and somewhat surprising reasons that can cause framerate to drop adding to usual driver issues, and perhaps this is the right time to put something to public knowledge, even though they may not have anything to do with your problem, Nick C, especially since you have problems with a clean game as well. But let's see...

    In the past (and perhaps even nowadays) having your Gmail account on was an interesting one because it single-handedly caused constant screen freezing, subtle or worse depending on your luck on any given day. So even though I'm not saying that something like Twitter would cause issues, but do not be surprised if it did. You might think "well that's just absurd, porridge's gone nuts, oh wait he's always been like that but now more nuttier than ever", but I'd advise you not to dismiss these theories instantly.

    The same can happen with certain antivirus software, but this is way harder to prove unless you're forced to make a program update after which any issues would start. So better just move on.

    Present: "HD" car skins. I noticed earlier in the year (January-February) that while the clean original skin of Fiesta WRC (yes, the boring one) caused no issues, installing a 4096x4096 skin downloaded from Rallyesim site was a disaster to say the least. And all that even if I used bumper cam. So when the car wasn't actually visible in the screen, the framerate was still a nightmare. It was like a good graphics engine all of a sudden changing to a codemasters one. :) I don't know if Rallyesim has introduced any of "HD skins" by default to any car or alongside their numerous updates, but I'd suggest one to try different cars with the same SS, and if there is a car that doesn't cause the issue, well... However it has to be said that the skin wouldn't necessarily be the problem in question 'cos there can be some other variables affecting the performance. But if someone ever found something, then the exact reasons could be asked from Rallyesim themselves.
     
  5. Nick,

    what about your settings related to v-sync of your video card and in the FixUp plugin ini file ?
    Do you play fullscreen or windowed ? Is there a difference when playing these modes?
     
  6. I've tried enabling/disabling the v-sync in the Nvidia control panel, though I'm not quite sure what the "FixUp" plugin is?
    Also I play fullscreen, haven't managed to get RBR to run windowed, so if you have any tips on that I'd appreciate it :)

    And Porridge, I don't play with any Gmail or Twitter or any browser running the background, nor do I have any HD skins. I tried disabling my antivirus though that didn't help :( Thanks a lot of trying though, I really appreciate it!
     
  7. edit the line in your RichardBurnsRally.ini to read Fullscreen = false
     
  8. http://www.racedepartment.com/rbr-mods/54077-download-rbr-fixup-patch-plugin-1-5-a.html

    There is written information about the plugin on the above link and also the possibility to download it.

    HTH,
    Pete
     
  9. my bad, i got it working:)
     
    Last edited: Oct 17, 2014