1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

rFactor not starting anymore

Discussion in 'rFactor' started by Lars Brugman, Apr 27, 2012.

  1. I click on the desktop icon for icon and then it stops doing anything. Anyone any ideas?
  2. Teemu Toikka

    Teemu Toikka
    Not so Flying Finn

    Have you tried running it as admin? Or have you tried starting it from the folder?
  3. [​IMG]
    This is the error I get.
  4. Just did a new clean install (again) and now it works again. Thanks for helping
  5. Ole Marius Myrvold

    Ole Marius Myrvold
    JWB 96-13 Staff

    @Lars Brugman
    Just a guess: You innstalled TV-display, or anything similar using d3d9.dll?
    Oh, if you use xfire, and anything that use d3d9.dll it will crash on startup.
  6. Yes I did. I don't use xfire though.
  7. Ole Marius Myrvold

    Ole Marius Myrvold
    JWB 96-13 Staff

    That might explain it. Sometimes rFactor just won't start when you install things that needs d3d9.dll. And if one or more addons needs that dll it's a higher chance of failure.
    I have no idea what's ultimately causing it though, it seems to be a bit of luck that decides it.

    The only thing I know is that if anyone wants to use xfire, then you can't have anything else using that dll.

    When you re-installed rF did you install all the addons/plugins that you did when it crashed?
  8. No not everything.
  9. I just installed f1 1985 (?) mod for rFactor and it stopped working again :(
    • Wow Wow x 1
  10. keep trying I have this from time to time and after a few tries it works again. It boots all track & cars after a few tries and this takes a while. After that everything works normal again.
  11. Hiroshi Awazu

    Hiroshi Awazu
    Off Topic Moderator

    I didn't want start another for this but the track Toban stopped working all of a sudden. When i select race it just CTD. All of my other tracks still work.

    What could of caused this to happen?

    Edit: I reinstalled, all is good again.