1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
Like RaceDepartment on Facebook.

rFactor doesn't start/recognize the CD/DVD anymore

Discussion in 'rFactor' started by PeterVox, Apr 5, 2010.

  1. rFactor doesn't start anymore! It says, I'd have to insert the correct cd/dvd and press [ok]. That's what I do but the game doesn't recognize the cd/dvd!

    I own the cd/dvd version, disc is inserted, game is patched to 1225F, it worked for a long time (last time yesterday) without any problem (running Windows Seven 64bit, game has admin-privileges) and now it stopped working! Nothing changed, system is still the same.

    I tried to find the reason, but I had no success. Disabled anti-virus software, firewall, Windows Defender, ... I reinstalled my cd/dvd-drive, changed the drive letter, ... game re-install, ... but nothing helped. :frown:

    I hope you know what to do to get the game running again?! :confused:
     
  2. have you tried right clicking the exe and run as admin?
     
  3. Yes, from the beginning on. :)
     
  4. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    As an alternative you can also download the full game from www.rfactor.net in case your disc is not working.
     
  5. You mean the v1255 full install?! I didn't purchase the download version so I can't activate it online, only the time demo will work, I assume?!
     
  6. Bram

    Bram
    Roaring Pipes Maniacs | #27 Staff Premium Member

    Hmm i don't know about that, but i think it should work the same way. The disc of rFactor i have is more or less a demo try/buy version. Not sure if rFactor was sold as a full game in stores to be honest.
     
  7. It's the full retail version on DVD. Secured by SafeDisc. Needs disc inserted to be played. But that is the problem now, it doesn't recognize the disc as the correct one anymore. :frown:
     
  8. I remember having something similar happen to me, DVD Spec. Ed.2008 version. I can't quite remember my solution though, it's my age you see. :)

    It's either I re-installed or I had removed a mod but missed something in the rfm folder and that was preventing it from starting. I am 70% sure I re-installed it though.
     
  9. Okay, checked the dvd, game still runs under XP (same folder). So there must be something wrong in my Windows Seven system. But what? :confused:
     
  10. turn off UAC?
     
  11. Yap, turned off. Did it some weeks ago.
     
  12. Bram the DVD version has no activation but a cd check it works totaly different to the demo cd/full version download wich needs
    to be activated on the ISI site, i know as i have this RF as boxed DVD version on my shelf :D

    Peter do you can access the DVD manualy in your DVD player, if not either the DVD or the Player is broken if you can accsse
    then save up all your player datas and mods and reinstall the game that should help
     
  13. Yes, I can browse and start the setup from the dvd, and I can start the game under XP, using the same folder as installed under Seven.
     
  14. hmmm i installed the game only under xp and just dropped the .exe on my win7 desktop and it works flawless, anyway that must not
    work for everyone so maybe install Rf new from win7 site and maybe in a different loacation as i cant say that it will work then under xp
     
  15. It worked before, so I don't think Windows Seven is the problem in general. Never had this problem, had already Vista, worked fine all the time.

    I think there must be something wrong with the copy-protection SafeDisc, something I can fix possibly.

    Perhaps it has something to do with the "All Points Bulletin" multiplayer beta game? I uninstalled it yesterday. Just an idea.
     
  16. i guess you had only dropped the .exe like me from your xp install on the win7 desktop so the uninstall
    of this beta should not have mess with your rf install as win 7 not even know its there untill you start it
    i tryed to send you a pm but that dident worked and the possible solution i cant post here
     
  17. Dave Stephenson

    Dave Stephenson
    Technical Administrator Staff Premium Member

    cant you just use the key in the Download edition. If you wanted to try it real quick you could download the 'Lite' edition from RFC, its only 100mb.
     
  18. PM is activated now. :)

    My boxed dvd version has no key, the only protection is the dvd check, and this check doesn't work anymore. I don't understand why. :rolleyes:

    I've installed the game under Seven and was already playing it under Seven. I've a dualboot and started the game under XP (from the same folder) to see if the disc is okay, if the installation of the game is okay, and both things are okay, there must be something else wrong. After reinstalling the game I still have to insert the disc and than the problem shows up again: Please insert the correct DVD-ROM... :confused:

    All my games run under Seven. XP is barely used and only for old things which do not work under Seven (I know there's an XP mode... :D).
     
  19. PM is out Peter and should help you
     
  20. The full install v1255 on this official site does not include the last F patch, does it? So I need both downloads, right?

    And what about the Lite version, does this one include the last F patch? And where do I get this? Only on rFCentral?